zoukankan      html  css  js  c++  java
  • 快速切题 poj 1002 487-3279 按规则处理 模拟 难度:0

    487-3279
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 247781   Accepted: 44015

    Description

    Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

    The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

    A, B, and C map to 2 
    D, E, and F map to 3 
    G, H, and I map to 4 
    J, K, and L map to 5 
    M, N, and O map to 6 
    P, R, and S map to 7 
    T, U, and V map to 8 
    W, X, and Y map to 9 

    There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

    Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

    Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

    Input

    The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

    Output

    Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

    No duplicates. 

    Sample Input

    12
    4873279
    ITS-EASY
    888-4567
    3-10-10-10
    888-GLOP
    TUT-GLOP
    967-11-11
    310-GINO
    F101010
    888-1200
    -4-8-7-3-2-7-9-
    487-3279
    

    Sample Output

    310-1010 2
    487-3279 4
    888-4567 3
    #include <iostream>
    #include <cstdio>
    #include <map>
    #include <string>
    #include <vector>
    #include <algorithm>
    using namespace std;
    map<string ,int> m;
    string str;
    vector <string> q;
    char readchar(){
        char ch;
        while(1){
            ch=getchar();
            if(ch>='A'&&ch<'Q'){
                ch=(ch-'A')/3+2+'0';
                break;
            }
            else if(ch>'Q'&&ch<'Z'){
                ch=(ch-'A'-1)/3+2+'0';
                break;
            }
            else if(ch<='9'&&ch>='0'){
                break;
            }
        }
        return ch;
    }
    int main(){
        int k;
    	cin>>k;
        while(k--){
            str="";
            for(int i=0;i<7;i++){
                str+=readchar();
            }
            if(m[str]){
                m[str]++;
            }
            else {
                m[str]=1;
                q.push_back(str);
            }
        }
        sort(q.begin(),q.end()-1);
        bool fl=true;
        for(vector<string>::iterator i=q.begin();i<q.end();i++){
            if(m[*i]>1){
                cout<<i->substr(0,3)<<"-"<<i->substr(3,4)<<" "<<m[*i]<<endl;
                fl=false;
            }
        }
        if(fl){
            cout<<"No duplicates."<<endl;
        }
    	return 0;
    }
    

      

  • 相关阅读:
    mysql随手记
    Exception 和 RuntimeException区别
    数据结构与算法
    Idea快捷键
    eclipse快捷键
    了解Lua语言中的_index,newindex,rawget和rawset
    Cocos2d-x CCNotificationCenter 通知中心
    LUA-赋值语句
    CCOrbitCamera:create
    类型和值
  • 原文地址:https://www.cnblogs.com/xuesu/p/4106221.html
Copyright © 2011-2022 走看看