zoukankan      html  css  js  c++  java
  • 杭电acm刷题(3):1062,Text Reverse 标签: 杭电acm 2017-05-15 08:26 126人阅读 评论(0)

    Problem Description

    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

    Input

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.

    Output

    For each test case, you should output the text which is processed.

    Sample Input

    3
    olleh !dlrow
    m’I morf .udh
    I ekil .mca

    Sample Output

    hello world!
    I’m from hdu.
    I like acm.

    程序思路:

    通过空格区分单词,每检测到一个空格更新指针,一个指向头的位置,一个指向尾的位置。

    程序:

    #include "iostream"
    #include "string"
    #include "stdio.h"
    
    using namespace std;
    
    int main()
    {
        int T;
        string str;
        int len;
        int cnt = 0;
        int start, end;
    
        cin >> T;
        getchar();
    
        for (int i = 0;i < T;i++)
        {
            getline(cin, str);
            len = str.size();
            str[len] = ' ';
    
            start = 0;
            for (int j = 0;j < len + 1;j++)
            {
                if (str[j] == ' ')
                {
                    end = j - 1;
                    for (int n = end;n >= start;n--)
                        cout << str[n];
                    start = j + 1;
                    if(j!=len)
                        cout << ' ';
                    else
                        cout << endl;
                }
            }
        }
    
        return 0;
    }

    补充:

    由于每个空格检测一次,所以还需要在接收到的字符串的最后补上一个空格。程序思路不难,很容易搞懂。

  • 相关阅读:
    bzoj2434: [Noi2011]阿狸的打字机
    bzoj2830: [Shoi2012]随机树
    题解,作业*2
    bzoj1901: Zju2112 Dynamic Rankings
    luogu P4178 Tree
    CF1042C Array Product 分类讨论+贪心
    CF946D Timetable 动态规划
    CF597C Subsequences 树状数组 + 动态规划
    CF912D Fishes 期望 + 贪心
    bzoj 4321 queue2 dp
  • 原文地址:https://www.cnblogs.com/xuhongbin/p/7134164.html
Copyright © 2011-2022 走看看