zoukankan      html  css  js  c++  java
  • STL 应用2 POJ 1007 DNA Sorting 题解 (STL完美解答)

    DNA Sorting
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 63845   Accepted: 25209

    Description

    One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

    You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

    Input

    The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

    Output

    Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

    Sample Input

    10 6
    AACATGAAGG
    TTTTGGCCAA
    TTTGGCCAAA
    GATCAGATTT
    CCCGGGGGGA
    ATCGATGCAT

    Sample Output

    CCCGGGGGGA
    AACATGAAGG
    GATCAGATTT
    ATCGATGCAT
    TTTTGGCCAA
    TTTGGCCAAA

    Source

    本题属于简单题,只要读懂题意就行了。 题意就是让你做排序,这里不多说了。想说的还是STL的两个算法在这里的应用:sort()和for_each()
    sort()是STL排序算法,有两个版本,分别是: sort(RandomAccessIterator  first, RandomAccessIterator  last),sort(RandomAccessIterator  first, RandomAccessIterator  last, Functor comp)。
    for_each原型:for_each(InputIterator first, InputIterator last, Functor f)。
    看看用STL写的AC源码:
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    int n, len;
    struct DNA
    {
    	char str[64];
    	int val;
    	DNA() : val(0) {}
    	void evalue() {
    		for (int i=len-1; i>=0; i--)
    			for (int j=i; j>=0; j--)
    				if ( str[j] > str[i] ) val++;
    	}
    }array[100];
    bool comp(const DNA& a, const DNA& b) {	return a.val < b.val; }
    void printdna(DNA& dna) {	puts(dna.str); }
    int main()
    {
    	scanf("%d%d", &len, &n);
    	for (int i=0; i<n; i++)
    	{
    		scanf("%s", array[i].str);
    		array[i].evalue();
    	}
    	sort(array, array+n, comp);
    	for_each(array, array+n, printdna);
    return 0;	
    }

  • 相关阅读:
    在zend framework框架中try{}catch(Exception e){}的跳转问题
    【上】安全HTTPS-全面具体解释对称加密,非对称加密,数字签名,数字证书和HTTPS
    iOS 图像处理-剪裁图像
    Delphi DBGrid记录全选和反选拖动处理
    在DbGrid中,不按下Ctrl,单击鼠标如何实现多选?谢谢
    在DBGrid中实现多选功能
    回车跳到下一个EDIT
    远程控制篇:用Delphi模拟键盘输入/鼠标点击
    SQL的拼接语句在DELPHI中怎么写
    Delphi DbGridEh实现表格没有内容的渐变效果
  • 原文地址:https://www.cnblogs.com/xusw/p/5205873.html
Copyright © 2011-2022 走看看