zoukankan      html  css  js  c++  java
  • F

    F - Piggy-Bank

    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

    InputThe input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
    OutputPrint exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
    Sample Input

    3
    10 110
    2
    1 1
    30 50
    10 110
    2
    1 1
    50 30
    1 6
    2
    10 3
    20 4
    Sample Output
    The minimum amount of money in the piggy-bank is 60.
    The minimum amount of money in the piggy-bank is 100.
    This is impossible.
    题意:多组输入 给出罐子的初始体积和当前体积(给出背包容量) 给出物品种类 给出物品价值和物品
    体积(v,w) 求所装的最小价值 完全背包问题
    注意:完全背包问题可以转化成01背包问题 但要把第二层循环变成正循环 求最小值初始化dp为大值
    #include <bits/stdc++.h>
    using namespace std;
    int w[50000],v[50000],dp[50000];
    int main()
    {
        int m,n,f,e,t;
        cin>>t;
        while(t--)
        {
            cin>>f>>e>>m;
            n=e-f;
            for(int i=0;i<m;i++)
            {
                cin>>v[i]>>w[i];
            }
            dp[0]=0;//  
            for(int i=1;i<=n;i++)
            {
                dp[i]=66666666;
            }
            for(int i=0;i<m;i++)
            {
                for(int j=w[i];j<=n;j++)//不能是(int j=n;j>=w[i];j--)
                {
                    dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
    
                }
            }
            if(dp[n]==66666666)
             cout<<"This is impossible."<<endl;
            else
             cout<<"The minimum amount of money in the piggy-bank is "<<dp[n]<<"."<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    python两个dict相加
    rpm命令
    python logging模块不支持多进程写到一个log文件
    技术论坛地址收集
    visudo命令编辑修改/etc/sudoers配置文件
    健康是什么
    .net文件类型种种
    禁止脚本的运行
    静态页面的值传递
    datagrid数据导出到excel文件给客户端下载的几种方法 (转)
  • 原文地址:https://www.cnblogs.com/xuxua/p/9278304.html
Copyright © 2011-2022 走看看