zoukankan      html  css  js  c++  java
  • 1.2.5 decimal system 40.03%(492,1229)

    Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1229 Accepted Submission(s): 492
     
    Problem Description
    As we know , we always use the decimal system in our common life, even using the computer. If we want to calculate the value that 3 plus 9, we just import 3 and 9.after calculation of computer, we will get the result of 12.
    But after learning <<The Principle Of Computer>>,we know that the computer will do the calculation as the following steps:
    1 computer change the 3 into binary formality like 11;
    2 computer change the 9 into binary formality like 1001;
    3 computer plus the two number and get the result 1100;
    4 computer change the result into decimal formality like 12;
    5 computer export the result;

    In the computer system there are other formalities to deal with the number such as hexadecimal. Now I will give several number with a kind of change method, for example, if I give you 1011(2), it means 1011 is a number in the binary system, and 123(10) means 123 if a number in the decimal system. Now I will give you some numbers with any kind of system, you guys should tell me the sum of the number in the decimal system.
     
    Input
    There will be several cases. The first line of each case contains one integers N, and N means there will be N numbers to import, then there will be N numbers at the next N lines, each line contains a number with such form : X1….Xn.(Y), and 0<=Xi<Y, 1<Y<=10. I promise you that the sum will not exceed the 100000000, and there will be at most 100 cases and the 0<N<=1000.
     
    Output
    There is only one line output case for each input case, which is the sum of all the number. The sum must be expressed using the decimal system.
     
    Sample Input
    3
    1(2)
    2(3)
    3(4)
    
    4
    11(10)
    11(2)
    11(3)
    11(4)
     
    Sample Output
    6
    23
     
     
    Source
    HDU 2007-6 Programming Contest
     
    Recommend
    xhd
    View Code
    #include<iostream>
    #include<stdio.h>
    using namespace std;
    long pow(long a,long b)
    {
    long i,ans=1;
    for(i=1;i<=b;i++)
    ans*=a;
    return ans;
    }
    long conv(long x,long y)
    {
    long a,s=0;
    long b,i=0;
    a=x;
    while(a){
    b=a%10;
    s+=b*pow(y,i);
    a=a/10;
    i++;
    }
    return s;
    }
    int main()
    {
    long n,i,j,y;
    long x,sum=0;
    char c;
    while(cin>>n){
    sum=0;//忘了归零
    for(i=0;i<n;i++){
    cin>>x>>c>>y>>c;
    sum+=conv(x,y);
    }
    cout<<sum<<endl;
    }
    return 0;
    }
  • 相关阅读:
    LeetCode 326. Power of Three
    LeetCode 324. Wiggle Sort II
    LeetCode 322. Coin Change
    LeetCode 321. Create Maximum Number
    LeetCode 319. Bulb Switcher
    LeetCode 318. Maximum Product of Word Lengths
    LeetCode 310. Minimum Height Trees (DFS)
    个人站点大开发!--起始篇
    LeetCode 313. Super Ugly Number
    LeetCode 309. Best Time to Buy and Sell Stock with Cooldown (DP)
  • 原文地址:https://www.cnblogs.com/yangshuo/p/2358240.html
Copyright © 2011-2022 走看看