zoukankan      html  css  js  c++  java
  • SDUT 1500-Message Flood(set)

    Message Flood

    Time Limit: 1500ms   Memory limit: 65536K  有疑问?点这里^_^

    题目描写叙述

    Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

    输入

    There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

    输出

    For each case, print one integer in one line which indicates the number of left friends he must send.

    演示样例输入

    5 3
    Inkfish
    Henry
    Carp
    Max
    Jericho
    Carp
    Max
    Carp
    0

    演示样例输出

    3

    来源

    第9届中山大学程序设计竞赛预选赛
     
    是一道字典树的题。额 眼下还不会敲字典树 先用set搞搞
    翻译一下:输入一个邮件好友列表(无反复名称) 再输入一个邮件发送列表(可能有反复),且这两个列表里的好友名字都不区分大写和小写(坑) 求未发送邮件好友的数目
     
    #include <iostream>
    #include <algorithm>
    #include <string.h>
    #include <cstdio>
    #include <cctype>
    #include <cmath>
    #include <string>
    #include <set>
    using  namespace std;
    int main()
    {
      ios::sync_with_stdio(false);
      int n,m;
      string x;
      while(cin>>n&&n)
     {
      cin>>m;
      set <string> s;
      while(n--)
      {
        cin>>x;
        for(int i=0;i!=x.size();i++)
        x[i]=tolower(x[i]);
        s.insert(x);
      }
      while(m--)
      {
        cin>>x;
        for(int i=0;i!=x.size();i++)
        x[i]=tolower(x[i]);
        if(s.count(x))
          s.erase(x);
      }
      cout<<s.size()<<endl;
     }
      return 0;
    }


  • 相关阅读:
    外贸术语缩写大全简写解释
    免费Shopify主题Dawn
    语音搜索对未来SEO的影响
    基于Prometheus和Grafana监控redis,Oracle,mysql,pg以及sqlserver的方法总结
    使用Grafana 监控 SQLSERVER数据库
    使用influxdb以及Grafana监控vCenter的操作步骤
    Grafana监控Redis的使用情况
    OpenPower服务使用node-exporter prometheus以及grafana进行性能监控的流程
    Mysql localhost 无法登录 root用户的处理过程
    总结: Redis 查看key大小的简单总结
  • 原文地址:https://www.cnblogs.com/yangykaifa/p/7097105.html
Copyright © 2011-2022 走看看