zoukankan      html  css  js  c++  java
  • 湖南省第八届大学生计算机程序设计竞赛C题 Updating a Dictionary

      湖南省第八届大学生计算机程序设计竞赛C题 Updating a Dictionary题目链接)。

    Problem C     Updating a Dictionary

    In this problem, a dictionary is collection of key-value pairs, where keys are lower-case letters, and values are non-negative integers. Given an old dictionary and a new dictionary, find out what were changed.

    Each dictionary is formatting as follows:

    {key:value,key:value,...,key:value}

    Each key is a string of lower-case letters, and each value is a non-negative integer without leading zeros or prefix `+'. (i.e. -4, 03 and +77 are illegal). Each key will appear at most once, but keys can appear in any order.

    Input

    The first line contains the number of test cases T ( T≤1000). Each test case contains two lines. The first line contains the old dictionary, and the second line contains the new dictionary. Each line will contain at most 100 characters and will not contain any whitespace characters. Both dictionaries could be empty.

    WARNING: there are no restrictions on the lengths of each key and value in the dictionary. That means keys could be really long and values could be really large.

    Output

    For each test case, print the changes, formatted as follows:

    • First, if there are any new keys, print `+' and then the new keys in increasing order (lexicographically), separated by commas.
    • Second, if there are any removed keys, print `-' and then the removed keys in increasing order (lexicographically), separated by commas.
    • Last, if there are any keys with changed value, print `*' and then these keys in increasing order (lexicographically), separated by commas.

    If the two dictionaries are identical, print `No changes' (without quotes) instead.

    Print a blank line after each test case.

    Sample Input

    3
    {a:3,b:4,c:10,f:6}
    {a:3,c:5,d:10,ee:4}
    {x:1,xyz:123456789123456789123456789}
    {xyz:123456789123456789123456789,x:1}
    {first:1,second:2,third:3}
    {third:3,second:2}

    Sample Output

    +d,ee
    -b,f
    *c

    No changes

    -first

      解题思路:题目要求按字典序输出,由于mapset都会按照operator<自动排序,正好string类有operator<函数,因此就用这两个。map映射一个key,value对。把旧字典的数据插入这个map中。新字典与它比较,如果没找到,添加到add集合中。如果找到了则删除,删除前判断value值是否相同,如果不同,就插入change集合。如此一来,没删除的就是"-"的元素。然后先后输出add集合、"-"的元素和change集合的元素即可。C++语言代码如下:

    #include <cstdio>
    #include <cstdlib>
    #include <string>
    #include <cctype>
    #include <map>
    #include <set>
    
    using namespace std;
    
    #define MAX_LENGTH 200
    
    int main ( )
    {
        int test_cases;
        char line[MAX_LENGTH];
        string  key, value;
        map <string, string> dic;
        set <string> add, change;
        scanf( "%d", &test_cases );
        gets( line );
        while ( test_cases -- )
        {
            key = value = "";
            dic.clear( );
            gets( line );
            for ( int i = 1 ; line[i] != '\0' ; i ++ )
            {
                if ( isdigit(line[i]) )
                    value += line[i];
                else if ( isalpha(line[i]) )
                    key += line[i];
                else if ( line[i] == ',' )
                {
                    dic.insert( make_pair<string, string>(key, value) );
                    key = value = "";
                }
                else if ( line[i] == '}' )
                {
                    if ( key != "" )
                        dic.insert( make_pair<string, string>(key, value) );
                    key = value = "";
                }
            }
    
            add.clear( );
            change.clear( );
            gets( line );
            for ( int i = 1 ; line[i] != '\0' ; i ++ )
            {
                if ( isdigit(line[i]) )
                    value += line[i];
                else if ( isalpha(line[i]) )
                    key += line[i];
                else if ( line[i] == ',' )
                {
                    map <string, string> :: iterator  it = dic.find( key );
                    if ( it == dic.end( ) )
                        add.insert( key );
                    else
                    {
                        if ( it->second != value )
                            change.insert( key );
                        dic.erase( it );
                    }
                    key = value = "";
                }
                else if ( line[i] == '}' )
                {
                    if ( key != "" )
                    {
                        map <string, string> :: iterator  it = dic.find( key );
                        if ( it == dic.end( ) )
                            add.insert( key );
                        else
                        {
                            if ( it->second != value )
                                change.insert( key );
                            dic.erase( it );
                        }
                        key = value = "";
                    }
                }
            }
    
            if ( dic.size( ) == 0 && add.size( ) == 0 && change.size( ) == 0 )
                puts( "No changes" );
            else
            {
                if ( add.size( ) != 0 )
                {
                    set <string> :: const_iterator  it;
                    it = add.begin( );
                    printf( "+%s", it->c_str( ) );
                    for ( ++ it ; it != add.end( ) ; ++ it )
                        printf( ",%s", it->c_str( ) );
                    puts( "" );
                }
                if ( dic.size( ) != 0 )
                {
                    map <string, string> :: const_iterator  it;
                    it = dic.begin( );
                    printf( "-%s", it->first.c_str( ) );
                    for ( ++ it ; it != dic.end( ) ; ++ it )
                        printf( ",%s", it->first.c_str( ) );
                    puts( "" );
                }
                if ( change.size( ) != 0 )
                {
                    set <string> :: const_iterator  it;
                    it = change.begin( );
                    printf( "*%s", it->c_str( ) );
                    for ( ++ it ; it != change.end( ) ; ++ it )
                        printf( ",%s", it->c_str( ) );
                    puts( "" );
                }
            }
            puts( "" );
        }
        return EXIT_SUCCESS;
    }
  • 相关阅读:
    struts2下,jsp视图页面中CSS和javascript引用相对路径和绝对路径问题。
    浏览器和web开发中的编码问题
    一台电脑同时配置2个tomcat
    hibernate中“deleted object would be re-saved by cascade”异常原理和解决方案
    hibernate Unknown entity异常解决方案
    rose2003安装后,启动时提示 计算机缺少suite objects.dll解决方案
    Eclipse下构建hibernate项目流程
    Hibernate不能自动建表解决办法【转载】
    Eclipse安装hibernate插件的问题
    MyEclipse添加tomcat7出现“Value must be an existing directory”解决方案
  • 原文地址:https://www.cnblogs.com/yejianfei/p/2729186.html
Copyright © 2011-2022 走看看