zoukankan      html  css  js  c++  java
  • Poj-1274-The Perfect Stall-匈牙利算法

    The Perfect Stall
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 19174   Accepted: 8696

    Description

    Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
    Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

    Input

    The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

    Output

    For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

    Sample Input

    5 5
    2 2 5
    3 2 3 4
    2 1 5
    3 1 2 5
    1 2 
    

    Sample Output

    4
    
    
    翻译:

    农夫约翰上个星期刚刚建好了他的新牛棚,他使用了最新的挤奶技术。

    不幸的是,因为project问题,每一个牛栏都不一样。

    第一个星期,农夫约翰随便地让奶牛们进入牛栏。可是问题非常快地显露出来:每头奶牛都仅仅愿意在她们喜欢的那些牛栏中产奶。上个星期。农夫约翰刚刚收集到了奶牛们的爱好的信息(每头奶牛喜欢在哪些牛栏产奶)。一个牛栏仅仅能容纳一头奶牛,当然,一头奶牛仅仅能在一个牛栏中产奶。

    给出奶牛们的爱好的信息,计算最大分配方案。

    #include <stdio.h>
    #include <string.h>
    #include <string>
    #include <math.h>
    #include <stdlib.h>
    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    #include<queue>
    #include<stack>
    using namespace std;
    int line[210][210];
    int used[210];
    int cow[210];
    int n,m;
    int find(int x)
    {
    	for(int i=1;i<=m;i++) //为这仅仅牛找一个棚 
    	{
    		if((line[x][i] && !used[i])) //假设这个牛棚适合这个牛 而且 这个棚没有其它牛 
    		{
    			used[i]=1;          //标记此棚有牛 
    			if(!cow[i] || find(cow[i]))// cow[i]这个棚还没有牛 或者 可以有牛的归宿 
    			{
    				cow[i]=x;    //标记此棚有牛 
    				return 1;
    			}
    		}
    	}
    	return 0;
    }
    int main()
    {
    	while(~scanf("%d %d",&n,&m))
    	{ 
    	int num=0;
    	int t,k; 
    	memset(line,0,sizeof(line)) ;
    	memset(cow,0,sizeof(cow));
    	for(int i=1;i<=n;i++)
    	{
    		cin>>t;
    		for(int j=1;j<=t;j++)
    		{
    			cin>>k;
    			line[i][k]=1;
    		}
    	}
    	for(int i=1;i<=n;i++)  
    	{
    		memset(used,0,sizeof(used));//为每仅仅牛找棚 前确保每一个棚都是空的 
    		if(find(i))
    		   num++; 
    	}
    	cout<<num<<endl;
    	} 
    return 0;
    }


    
       
    
  • 相关阅读:
    从零开始在阿里云服务器(Ubuntu)上部署Rails应用
    rspec使用
    ubuntu安装和配置SVN
    给asp:DropDownList追加项到顶层显示
    js生成、删除表格方法
    js验证
    GridView和CheckBox连用,实现全选
    javascript;css;firefox;ie;区别
    回调示例
    GridView联合CheckBox实现全选功能[百度空间搜集]
  • 原文地址:https://www.cnblogs.com/yfceshi/p/6764771.html
Copyright © 2011-2022 走看看