zoukankan      html  css  js  c++  java
  • hdu 1710 Binary Tree Traversals 前序遍历和中序推后序

    题链;http://acm.hdu.edu.cn/showproblem.php?pid=1710

    Binary Tree Traversals

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4205    Accepted Submission(s): 1904


    Problem Description
    A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

    In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

    In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

    In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

    Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
     

    Input
    The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
     

    Output
    For each test case print a single line specifying the corresponding postorder sequence.
     

    Sample Input
    9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
     

    Sample Output
    7 4 2 8 9 5 6 3 1
     

    题意:给出前序历遍和中序遍历的顺序,来推导后序遍历的顺序。
    做法:把握两个要点。前序是 先根历遍的。所曾经序的第一个是根。

    然后这个根把中序分为两半,左边是左子树,右边是右子树。

    然后递归下就ok了。



    #include <cstdio>
    #include <algorithm>
    using namespace std;
    
    struct tree
    {
    	struct tree* l;
    	struct tree* r;
    	int val; 
    	tree()
    	{
    		l=NULL;
    		r=NULL;
    	}
    }; 
    
    int pre[1010],in[1010];
    int n;
    tree* root;
    void build(int num,int l,int r,tree *rt)//pre num   in_l  in_r
    {
    	int flag=-1;
    	while(flag==-1)
    	{
    		for(int i=l;i<=r;i++)
    		{
    			if(pre[num]==in[i])
    				flag=i;
    		}
    		if(flag==-1)
    			num++;
    	}
    	if(flag-l>0)
    	{
    		rt->l=(tree*)malloc(sizeof(tree));
    		*(rt->l)=tree();
    		build(num+1,l,flag-1,rt->l);
    	}
    	if(r-flag>0)
    	{
    		rt->r=(tree*)malloc(sizeof(tree));
    		*(rt->r)=tree();
    		build(num+1,flag+1,r,rt->r);
    	}
    	rt->val=pre[num];
    }
    
    void post(tree* nw)
    {
    	if(nw->l!=NULL)
    	post(nw->l);
    	if(nw->r!=NULL)
    	post(nw->r);
    
    	if(nw==root)
    		printf("%d",nw->val);
    	else
    		printf("%d ",nw->val);
    
    }
    
    void del(tree* nw)
    {
    	if(nw->l!=NULL)
    	del(nw->l);
    	if(nw->r!=NULL)
    	del(nw->r);
    	free(nw);
    }
    
    int main() 
    {
    	while(scanf("%d",&n)!=EOF)
    	{
    		for(int i=0;i<n;i++)
    			scanf("%d",&pre[i]);
    		for(int i=0;i<n;i++)
    			scanf("%d",&in[i]); 
    		root=(tree*)malloc(sizeof(tree));
    		*root=tree();
    		build(0,0,n-1,root); 
    		post(root);
    		puts(""); 
    		del(root);  
    	} 
    	return 0;
    } 




  • 相关阅读:
    TOEFL资料 280多个
    Eclipse搭建J2ME开发环境
    Session.Abandon和Session.Clear有何不同
    进程之同步、互斥PV操作笔记
    Windows Mobile 6.5 实现联系人分组显示
    关于数据库的版本控制
    xhtml的布局,满屏,高度自适应
    MOSS 项目模板
    DNN中与模块相关的信息
    J2EE学习笔记
  • 原文地址:https://www.cnblogs.com/yfceshi/p/7191127.html
Copyright © 2011-2022 走看看