zoukankan      html  css  js  c++  java
  • HDU (a+k)%7 阅读题

    Problem K

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    Total Submission(s) : 60   Accepted Submission(s) : 55
    Problem Description
    BaoBao has just found a positive integer sequence $a_1, a_2, dots, a_n$ of length $n$ from his left pocket and another positive integer $b$ from his right pocket. As number 7 is BaoBao's favorite number, he considers a positive integer $x$ lucky if $x$ is divisible by 7. He now wants to select an integer $a_k$ from the sequence such that $(a_k+b)$ is lucky. Please tell him if it is possible.

    Input

    There are multiple test cases. The first line of the input is an integer $T$ (about 100), indicating the number of test cases. For each test case:

    The first line contains two integers $n$ and $b$ ($1 le n, b le 100$), indicating the length of the sequence and the positive integer in BaoBao's right pocket.

    The second line contains $n$ positive integers $a_1, a_2, dots, a_n$ ($1 le a_i le 100$), indicating the sequence.

    Output

    For each test case output one line. If there exists an integer $a_k$ such that $a_k in {a_1, a_2, dots, a_n}$ and $(a_k + b)$ is lucky, output "Yes" (without quotes), otherwise output "No" (without quotes).

    Sample Input

    4
    3 7
    4 5 6
    3 7
    4 7 6
    5 2
    2 5 2 5 2
    4 26
    100 1 2 4
    

    Sample Output

    No
    Yes
    Yes
    Yes
    

    Hint

    For the first sample test case, as 4 + 7 = 11, 5 + 7 = 12 and 6 + 7 = 13 are all not divisible by 7, the answer is "No".

    For the second sample test case, BaoBao can select a 7 from the sequence to get 7 + 7 = 14. As 14 is divisible by 7, the answer is "Yes".

    For the third sample test case, BaoBao can select a 5 from the sequence to get 5 + 2 = 7. As 7 is divisible by 7, the answer is "Yes".

    For the fourth sample test case, BaoBao can select a 100 from the sequence to get 100 + 26 = 126. As 126 is divisible by 7, the answer is "Yes".

     给定数列如果存在 (ai+k)%7==0输出Yes否则输出No
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cmath>
    #include <cstdio>
    
    using namespace std ; 
    
    #define maxn 110000
    int num[maxn] ; 
    
    int main(){
        int t ; 
        int n , m ; 
    
        cin >> t ; 
        while(t--){
            cin >> n >> m ; 
            bool flag = false ; 
            for(int i=1 ; i<=n ; i++){
                cin >> num[i] ; 
                num[i] = num[i] + m ;
                if(num[i]%7==0){
                    flag = true ; 
                } 
            }
            if(flag == true){
                cout << "Yes"<<endl ; 
            }else {
                cout<<"No"<<endl ; 
            }
        }
    
        return 0 ; 
    }
  • 相关阅读:
    【基本知识】verilog中 `define 的使用
    netsuite弹出窗体的数据回传例子
    js使用confirm对用户的行为进行判断 和prompt
    银行支付 接口
    关于IT公司的预见性
    js fix小数点 和int的区别
    ajax和Java session监听
    NetSuite全功能介绍 totemsuite netsuite开发模块
    财务软件间的财务接口(转载)
    去除eclipise f2功能 去除浮动窗口
  • 原文地址:https://www.cnblogs.com/yi-ye-zhi-qiu/p/9064954.html
Copyright © 2011-2022 走看看