zoukankan      html  css  js  c++  java
  • HDU1005(周期问题)

    Description

    A number sequence is defined as follows: 

    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

    Given A, B, and n, you are to calculate the value of f(n). 
     

    Input

    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 
     

    Output

    For each test case, print the value of f(n) on a single line. 
     

    Sample Input

    1 1 3 1 2 10 0 0 0
     

    Sample Output

    2 5
     
    程序分析:一开始看到这题我就直接跳过了。。

    但是后来发现还是有些规律的,对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过循环节出现了,注意循环节并不一定会是开始的 1,1 。 又因为一组测试数据中f[n]只有49中可能的答案,最坏的情况是所有的情况都遇到了,那么那也会在50次运算中产生循环节。找到循环节后,就可以解决此题

    注意:周期的大小,有可能是大周期,有可能是小周期!

    程序代码:
    #include<iostream>
    using namespace std;
    int f[54]={0,1,1};
    int main()
    {
        int A,B,n,q=1;
    while(cin>>A>>B>>n&&A&&B&&n)
    {
        for(int i=3;i<54;++i)
    {
        f[i]=(A*f[i-1]+B*f[i-2])% 7;
        if(i>4)
    {if(f[i-1]==f[3]&&f[i]==f[4])
        {
           q=i-4;  //要特别注意,可以想一下为什么?
    
        }
    }
        }
    cout<<f[n%q]<<endl;
    
    }
    
    return 0;
    }
    
    
    
    
    
  • 相关阅读:
    基本语句
    mysql多表查询方法(join)
    MySQL JOIN 多表连接
    MySQL SHOW INDEX语法的实际应用
    1.索引作用
    MySQL索引和优化查询
    mysql复合索引、普通索引总结
    mysql 索引相关
    for循环的break和continue
    保护程序猿滴眼睛---修改VS 2012 编辑器颜色
  • 原文地址:https://www.cnblogs.com/yilihua/p/4678503.html
Copyright © 2011-2022 走看看