zoukankan      html  css  js  c++  java
  • HDU 1004 Let the Balloon Rise(map的使用)

    传送门:

    http://acm.hdu.edu.cn/showproblem.php?pid=1004

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 143275    Accepted Submission(s): 56670


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     
    Sample Output
    red
    pink
     
    Author
    WU, Jiazhi
     
     
    题目意思:
    找颜色单词出现得最多的那个单词
    分析:
    map的用法
    很方便呀
    原来都没有怎么用过
    第一次用
    开心
    好用
    code:
    #include<bits/stdc++.h>
    using namespace std;
    int main()
    {
        int n;
        while(cin>>n,n)
        {
            map<string,int> mm;
            map <string,int>::iterator it;
            string ch;
            for(int i=0;i<n;i++)
            {
                cin>>ch;
                mm[ch]++;
            }
            int sum=0;
            string str;
            for(it=mm.begin();it!=mm.end();it++)
            {
               if(it->second>sum)
               {
                   sum=it->second;
                   str=it->first;
               }
            }
            cout<<str<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Java项目中读取properties文件,以及六种获取路径的方法
    在eclipse中使用JUnit4,以及使用JUnit4进行单元测试的技巧
    [Evernote]印象笔记使用经验技巧
    使用Word2010发布博客文章
    Win7/8 绿色软件开机启动
    常见笔试题
    排序
    数据库知识归纳(索引)
    数据库知识归纳(事务)
    Redis
  • 原文地址:https://www.cnblogs.com/yinbiao/p/9295827.html
Copyright © 2011-2022 走看看