zoukankan      html  css  js  c++  java
  • HDU 1258 Sum It Up(dfs 巧妙去重)

    传送门:

    http://acm.hdu.edu.cn/showproblem.php?pid=1258

    Sum It Up

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7758    Accepted Submission(s): 4067


    Problem Description
    Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
     
    Input
    The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
     
    Output
    For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
     
    Sample Input
    4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
     
    Sample Output
    Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
     
    Source
     
    Recommend
    JGShining   |   We have carefully selected several similar problems for you:  1045 1195 1067 1426 1242 
     
    题目意思:
    给定一个非递减的序列,要求从这些序列中找出一系列的数相加等于要求的数。
    主要就是我们需要对结果去重!
    这里有一共很巧妙的办法
    当你要搜的数字刚好前一步搜了,那么跳过你要搜的数字(直接看代码更好理解)
    还有就是这个dfs的框架也很重要
    关于到它到底是怎么搜的
    我觉得很受启发
    code:
    #include<iostream>
    #include<algorithm>
    #include<stdio.h>
    #include<queue>
    #include<set>
    #include<map>
    #include<string>
    #include<memory.h>
    using namespace std;
    #define max_v 25
    int sum,n;
    int a[max_v];
    int ans[max_v];
    int flag;
    bool cmp(int x,int y)
    {
        return x>y;
    }
    void dfs(int now,int s,int f)//现在的和 开始位置 结束位置
    {
        if(now>sum)//没有搜到
            return ;
        if(now==sum)//搜到 输出
        {
            cout<<ans[0];
            for(int i=1;i<f;i++)
            {
                cout<<"+"<<ans[i];
            }
            cout<<endl;
            flag=1;
        }
        for(int i=s;i<n;i++)
        {
            ans[f]=a[i];
            dfs(now+a[i],i+1,f+1);
            while(i+1<n&&a[i]==a[i+1])//搜完后,若下一个要搜的和搜完的一样 跳过
            {
                i++;
            }
        }
    }
    int main()
    {
        while(cin>>sum>>n)
        {
            if(sum==0&&n==0)
                break;
            int allsum=0;
            for(int i=0;i<n;i++)
            {
                cin>>a[i];
                allsum+=a[i];
            }
            cout<<"Sums of "<<sum<<":"<<endl;
            if(allsum<sum)
            {
                cout<<"NONE"<<endl;
                continue;
            }
            sort(a,a+n,cmp);
            flag=0;
            dfs(0,0,0);
            if(flag==0)
            {
                cout<<"NONE"<<endl;
            }
        }
        return 0;
    }
     
  • 相关阅读:
    5.4 省选模拟赛 修改 线段树优化dp 线段树上二分
    一本通 高手训练 1782 分层图 状压dp
    luogu P3830 [SHOI2012]随机树 期望 dp
    5.2 省选模拟赛 或许 线型基
    luogu P4562 [JXOI2018]游戏 组合数学
    一本通 高手训练 1781 死亡之树 状态压缩dp
    luogu P4726 【模板】多项式指数函数 多项式 exp 牛顿迭代 泰勒展开
    4.28 省选模拟赛 负环 倍增 矩阵乘法 dp
    HDU 1756 Cupid's Arrow 计算几何 判断一个点是否在多边形内
    一本通 高手训练 1763 简单树 可持久化线段树 树链刨分 标记永久化
  • 原文地址:https://www.cnblogs.com/yinbiao/p/9356317.html
Copyright © 2011-2022 走看看