zoukankan      html  css  js  c++  java
  • HDU 1003 Max Sum (动规)

    Max Sum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 141547    Accepted Submission(s): 32929



    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     

    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     

    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     

    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6
     

    Author
    Ignatius.L
     

    Recommend
    We have carefully selected several similar problems for you:  1176 1069 2084 1058 1159
    此题与HDU 1231一样,只是简单一些,记录前标要easy。
    #include <iostream>
    using namespace std;
    #define M 100100
    int vis[M],dp[M];
    int main(int i,int j,int k)
    {   
        int n,last,t,first,temp;
        cin>>t;
        for(k=1;k<=t;k++)
        {    
            cin>>n;
            memset(dp,0,sizeof(dp));
            for(i=1;i<=n;i++) {cin>>vis[i];dp[i]=vis[i];}
            int    sum=0,maxSum=vis[1];first=last=temp=1;
            for(i = 1; i <= n; i++)
            {
                sum += vis[i];          //i是从1開始的,所以先加再推断。

    if(sum > maxSum){ maxSum = sum; first = temp; last = i; } if(sum < 0){ //这里用sum表示vis[first]->vis[i]的和,所以要清零。

    sum = 0; temp = i+1; } } printf("Case %d: ",k); printf("%d %d %d ",maxSum,first,last); if(k < t) printf(" "); 好吧,这里就让我格式错误了几次。。。明明Case 1:和Case 2:数据中间有空行,可是完毕一次没空行。

    。 } return 0; }


  • 相关阅读:
    通过JDBC连接HiveServer2
    HDP-2.6.1安装
    VMWare虚拟机NAT模式静态IP联网配置
    基于ansj_seg和nlp-lang的简单nlp工具类
    修改ES使用root用户运行
    使用MapReduce将HDFS数据导入到HBase(三)
    HBase表操作
    使用SpringMVC解决Ajax跨域问题
    SpringBoot之Web开发——webjars&静态资源映射规则
    thymeleaf+springboot找不到html,只返回了字符串
  • 原文地址:https://www.cnblogs.com/yjbjingcha/p/6881962.html
Copyright © 2011-2022 走看看