zoukankan      html  css  js  c++  java
  • HDOJ 5417 Victor and Machine 水



    Victor and Machine

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
    Total Submission(s): 240    Accepted Submission(s): 134


    Problem Description
    Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball every w seconds. However, the machine has some flaws, every time after x seconds of process the machine has to turn off for y seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.

    Now, at the 0 second, the machine opens for the first time. Victor wants to know when the n-th ball will be popped out. Could you tell him?
     

    Input
    The input contains several test cases, at most 100 cases.

    Each line has four integers xyw and n. Their meanings are shown above。



    1x,y,w,n100.

     

    Output
    For each test case, you should output a line contains a number indicates the time when the n-th ball will be popped out.
     

    Sample Input
    2 3 3 3 98 76 54 32 10 9 8 100
     

    Sample Output
    10 2664 939
     

    Source
     


    /* ***********************************************
    Author        :CKboss
    Created Time  :2015年08月22日 星期六 21时57分18秒
    File Name     :HDOJ5417.cpp
    ************************************************ */
    
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <string>
    #include <cmath>
    #include <cstdlib>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    
    using namespace std;
    
    int x,y,w,n;
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
    
        while(cin>>x>>y>>w>>n)
        {
            int X=x;
            int time=0;
            for(int i=2;i<=n;i++)
            {
                if(time+w<=x)
                {
                    time+=w;
                }
                else
                {
                    time=x;
                    time+=y;
                    x=x+y+X;
                }
            }
            cout<<time<<endl;
        }
        
        return 0;
    }


  • 相关阅读:
    idea spring boot 1.x junit单元测试
    linux oracle/jdk启用大页面
    jdk8之CompletableFuture与CompletionService
    gc日志深入解析-覆盖CMS、并行GC、G1、ZGC、openj9
    h2 web console使用
    LockSupport工具类详解
    反射、Unsafe、直接调用性能大比拼
    spring boot druid动态多数据源监控集成
    Linux网络
    org.springframework.jdbc.CannotGetJdbcConnectionException: Could not get JDBC Connection总结
  • 原文地址:https://www.cnblogs.com/yjbjingcha/p/7265643.html
Copyright © 2011-2022 走看看