zoukankan      html  css  js  c++  java
  • 1009 Product of Polynomials (25)(25 point(s))

    problem

    This time, you are supposed to find A*B where A and B are two polynomials.
    
    Input Specification:
    
    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
    
    Output Specification:
    
    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
    
    Sample Input
    
    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    Sample Output
    
    3 3 3.6 2 6.0 1 1.6
    

    tip

    求多项式的乘积。

    answer

    #include<bits/stdc++.h>
    using namespace std;
    #define INF 0x3f3f3f3f
    #define Max 1000005
    
    int N, M;
    float num[Max];
    pair<int ,float> n1[Max], n2[Max];
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	memset(num, 0, sizeof(num));
    	memset(n1, 0, sizeof(n1));
    	memset(n2, 0, sizeof(n2));
    	
    	cin>>N;
    	for(int i = 0; i < N; i++) {
    		cin>>n1[i].first>>n1[i].second;
    	}
    	cin>>M;
    	for(int i = 0; i < M; i++) {
    		cin>>n2[i].first>>n2[i].second;
    	}
    	int number = 0;
    	for(int i = 0; i < N; i++){
    		for(int j = 0; j < M; j++){
    			int ex = n1[i].first + n2[j].first;
    			float co = n1[i].second * n2[j].second;
    			num[ex] += co;
    		}
    	}
    	for(int i = 0; i < Max; i++) if(num[i] != 0) number ++;
    	cout<<number;
    	for(int i = Max -1; i >= 0; i--){
    		if(num[i] != 0){
    			cout<<" "<<i<<" ";
    			cout<<fixed<<setprecision(1)<<num[i];
    		}
    	}
    	
    	return 0;
    }
    

    experience

    • 注意数组越界问题。
    • 读清楚题意,多设计一组测试用例。
  • 相关阅读:
    Maven错误recv failed
    eclipse集成tomcat修改字符集参数
    eclipse luna 无法安装veloeclipse问题
    TortoiseSVN忽略文件夹
    类之特性
    __new()__与__init__()
    flask中models设计
    flask读书记录
    JS中的event 对象详解
    redis 持久化 RDB
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9270837.html
Copyright © 2011-2022 走看看