zoukankan      html  css  js  c++  java
  • 1017 Queueing at Bank (25)(25 point(s))

    problem

    Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.
    
    Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.
    
    Input Specification:
    
    Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.
    
    Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.
    
    Output Specification:
    
    For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.
    
    Sample Input:
    
    7 3
    07:55:00 16
    17:00:01 2
    07:59:59 15
    08:01:00 60
    08:00:00 30
    08:00:02 2
    08:03:00 10
    Sample Output:
    
    8.2
    

    tip

    模拟题

    answer

    #include<algorithm> 
    #include<iomanip> 
    #include<iostream>
    #include<vector>
    #include<queue>
    
    #define INF 0x3f3f3f3f
     
    using namespace std;
    int N, K, Begin, End;
    
    typedef struct {
    	int arr, begin, end, pro, wait;
    }People;
    vector<People> p;
    queue<People> q[110];
    
    int TranTime(string t){
    	int hour = 0, minute = 0, second = 0;
    	hour = (t[0]-'0')*10+t[1]-'0';
    	minute = (t[3]-'0')*10+t[4]-'0';
    	second = (t[6]-'0')*10+t[7]-'0';
    	
    	return (hour)*60*60 + minute*60 + second;
    }
    
    bool Comp(People a, People b){
    	return a.arr < b.arr;
    }
    
    void Push(People &t){
    	int min = INF, index = 0;
    	bool flag = false;
    	for(int i = 0; i < K; i++){
    		if(q[i].empty()) {
    			index = i;
    			flag = true;
    			continue;
    		}
    		if(q[i].back().end < min && !flag) {
    			min = q[i].back().end;
    			index = i;
    		}
    	}
    //	cout<<index<<endl;
    	if(flag){
    		if(t.arr < Begin){
    			t.begin = Begin;
    			t.wait  = Begin - t.arr;
    		}else{
    			t.begin = t.arr;
    			t.wait = 0;
    		}
    		t.end = t.begin + t.pro;
    		q[index].push(t);
    	}else{
    		if(t.arr < q[index].back().end){
    			t.begin = q[index].back().end;
    			t.wait =  q[index].back().end - t.arr;
    		}else{
    			t.begin = t.arr;
    			t.wait = 0;
    		}
    		t.end = t.begin + t.pro;
    		q[index].push(t);
    	}
    //	cout<<t.arr/(3600)<<":"<<t.arr%(3600)/60<<" "<<t.begin/(3600)<<":"<<t.begin%(3600)/60<<" "<<t.end/(3600)<<":"<<t.end%(3600)/60<<" "<<t.wait/60<<" "<<t.pro/60<<" "<<endl;
    }
    
    void Pop(){
    	
    }
    
    void PrintStatus(){
    	for(int i = 0; i < K; i++){
    		cout<<i<<endl;
    		for(int j = 0; j < q[i].size(); j++){
    			cout<<q[i].front().begin/(60*60)<<":"<<q[i].front().begin%(60*60) /60<<" "<<q[i].front().end/(60*60)<<":"<<q[i].front().end%(60*60) /60<<" "<<q[i].front().wait<<endl;
    			q[i].push(q[i].front());
    			q[i].pop();
    		}
    		cout<<endl;
    	}
    }
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	ios::sync_with_stdio(false);
    	
    	Begin = TranTime("08:00:00");
    	End   = TranTime("17:00:00");
    	cin>>N>>K;
    	for(int i = 0; i < N; i++){
    		string time;
    		int pro;
    		cin>>time>>pro;
    		People tp;
    		tp.arr = TranTime(time);
    		tp.pro = pro*60;
    		if(tp.arr > End) continue;
    		p.push_back(tp);
    	}
    	sort(p.begin(), p.end(), Comp);
    	
    	for(int i = 0; i < p.size(); i++){
    		Push(p[i]);
    //		PrintStatus();
    	}
    //	PrintStatus();
    	float wait = 0.0;
    	for(int i = 0; i < p.size(); i++){
    		wait += p[i].wait / 60.0;
    	}
    	cout<<fixed<<setprecision(1)<<wait/p.size()<<endl;
    	return 0;
    }
    /*
    7 3
    07:55:00 16
    17:00:01 2
    07:59:59 15
    08:01:00 60
    08:00:00 30
    08:00:02 2
    08:03:00 10
    */ 
    

    exprience

    • 应该在30分钟内解决的一个简单模拟题,因为写代码时思考的太少而导致debug时间太长。
  • 相关阅读:
    mysql 存储过程实例
    国际会议查询方式和相关会议
    用 WEKA 进行数据挖掘,第 1 部分: 简介和回归(转)
    java实现甘特图的2种方法:SwiftGantt和Jfree (转)
    通过jxl 读取excel 文件中的日期,并计算时间间隔
    R 操作矩阵和计算SVD的基本操作记录
    SVD java 算法实现
    聚类方法简介
    Kolmogorov-Smirnov检验
    Java Thread 多线程 介绍
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9314708.html
Copyright © 2011-2022 走看看