zoukankan      html  css  js  c++  java
  • 1020 Tree Traversals (25)(25 point(s))

    problem

    Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
    
    Input Specification:
    
    Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
    
    Output Specification:
    
    For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
    
    Sample Input:
    
    7
    2 3 1 5 7 6 4
    1 2 3 4 5 6 7
    Sample Output:
    
    4 1 6 3 5 7 2
    

    tip

    给出后序与中序遍历,要求层次遍历。

    answer

    #include<iostream>
    #include<queue>
    #define Max 33
    
    using namespace std;
    
    int n, back[Max], mid[Max];
    //int tree[Max];
    struct Node{
    	int d;
    	Node *l;
    	Node *r;
    };
    Node *root;
    
    void Print(){
    	queue<Node*> q;
    	q.push(root);
    	while(!q.empty()){
    		Node *t = q.front(); q.pop();
    		if(!t->d) continue;
    		if(!t->l && !t->r && q.empty()) cout<<t->d;
    		else cout<<t->d<<" ";
    		
    		if(t->l) q.push(t->l);
    		if(t->r) q.push(t->r);
    	}
    //	cout<<endl;
    }
    
    Node* DFS(int left, int right, int midLeft, int midRight){
    	if(left > right) return NULL;
    	
    	Node *a = new Node();
    	int num = back[right];
    	int numIndex = -1;
    	for(int i = midLeft; i <= midRight; i++){
    		if(mid[i] == num) numIndex = i;
    	}
    	int lNum = numIndex - midLeft, rNum = midRight - numIndex;
    	a->d = num;
    	Print();
    	a->l = DFS(left, left + lNum -1, numIndex - lNum, numIndex-1);
    	a->r = DFS(right-rNum, right-1, numIndex+1, numIndex+rNum);
    	return a;
    }
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	ios::sync_with_stdio(false);
    	
    	cin>>n;
    	for(int i = 0; i < n; i++){
    		cin>>back[i];
    	}
    	for(int i = 0; i < n; i++){
    		cin>>mid[i];
    	}
    	root = new Node();
    	root = DFS(0, n-1, 0, n-1);
    	Print();
    	return 0;
    }
    

    exprience

    • 二叉树要多写几次,就熟悉了。
  • 相关阅读:
    CSS hack——不同浏览器的CSS应对法
    IE6对CSS支持Bug收集
    jQuery
    jQuery学习备忘
    MSSQLSERVER之发布-分发-订阅
    利用Resgen.exe 批量生成resources文件
    多语言处理
    c# winform 打包部署 自定义界面 或设置开机启动
    C#修改文件夹权限
    VS2008 Windows Form项目安装包生成详解
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9320838.html
Copyright © 2011-2022 走看看