zoukankan      html  css  js  c++  java
  • 1032 Sharing (25)(25 point(s))

    problem

    To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.
    
     Figure 1
    
    You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).
    
    Input Specification:
    
    Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5^), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.
    
    Then N lines follow, each describes a node in the format:
    
    Address Data Next
    
    where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.
    
    Output Specification:
    
    For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.
    
    Sample Input 1:
    
    11111 22222 9
    67890 i 00002
    00010 a 12345
    00003 g -1
    12345 D 67890
    00002 n 00003
    22222 B 23456
    11111 L 00001
    23456 e 67890
    00001 o 00010
    Sample Output 1:
    
    67890
    Sample Input 2:
    
    00001 00002 4
    00001 a 10001
    10001 s -1
    00002 a 10002
    10002 t -1
    Sample Output 2:
    
    -1
    

    tip

    • 模拟指针

    answer

    #include<iostream>
    #include<stack> 
    
    #define Max 100010
    using namespace std;
    
    struct Node{
    	int t;
    	char d;
    	bool flag;
    }node[Max];
    int N, f1, f2;
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	for(int i = 0; i < Max; i++) node[i].t = -1;
    	scanf("%d%d%d", &f1, &f2, &N);
    	int f, t; char d;
    	for(int i = 0; i < N; i++){
    		scanf("%d %c %d", &f, &d, &t);
    		node[f] = {t, d, false};
    	}
    	for(int i = f1; i != -1; i = node[i].t) node[i].flag = true;
    	for(int i = f2; i != -1; i = node[i].t){
    		if(node[i].flag ) {
    			printf("%05d", i);
    			return 0;
    		}
    	}
    	printf("-1");
    	return 0;
    }
    

    experience

  • 相关阅读:
    JS在线编辑器
    meta标签
    webstorm快捷键
    微信JS-SDK调用
    iOS -- UIApplication
    Xcode -- apple llvm 6.0 error错误如何解决
    C -- 字符串数组与字符串指针
    MAC -- 小技巧
    C语言 -- 折半查找小程序
    C -- 小程序
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9351219.html
Copyright © 2011-2022 走看看