zoukankan      html  css  js  c++  java
  • 数据结构之 线性表 逆序简历链表

    数据结构实验之链表二:逆序建立链表

    Time Limit: 1000MS Memory limit: 65536K

    题目描述

    输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

    输入

    第一行输入整数N;;
    第二行依次输入N个整数,逆序建立单链表。

    输出

    依次输出单链表所存放的数据。

    示例输入

    10
    11 3 5 27 9 12 43 16 84 22 

    示例输出

    22 84 16 43 12 9 27 5 3 11 

    比顺序创建链表还要简单!
    #include <iostream>
    #include <string>
    #include <string.h>
    #include <stdio.h>
    #include <algorithm>
    #include <algorithm>
    
    using namespace std;
    
    struct node
    {
        int data;
        struct node *next;
    };
    
    int main()
    {
        int n;
        int i, j;
    
        struct node *head;
        head= new struct node;
    
        head->next=NULL;
        struct node *p;
    
        cin>>n;
        for(i=0; i<n; i++)
        {
            p=new struct node;
            scanf("%d", &p->data );
            p->next=head->next;
            head->next=p;
        }
    
        for(j=0; j<n; j++)
        {
            if(j==0)
            cout<<head->next->data;
            else
            cout<<" "<<head->next->data;
            head=head->next;
        }
        cout<<endl;
    
        return 0;
    }
    
    
    
  • 相关阅读:
    Fedora/CentOS/RHEL删除旧的内核
    Linux下使Shell命令脱离终端运行
    保持tmux窗口名更改后不变
    Centos7 修改ssh 默认端口号
    验证码生成代码
    Json帮助类代码
    Http请求代码
    cookies读写代码
    缓存读写代码
    数据读写 CommonCurd
  • 原文地址:https://www.cnblogs.com/yspworld/p/4089899.html
Copyright © 2011-2022 走看看