zoukankan      html  css  js  c++  java
  • poj-2403-cup

    题目描述

    The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?

    The radius of the cup‘s top and bottom circle is known, the cup‘s height is also known.

    输入

    The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases. Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water. Technical Specification

    1. T <= 20.

    2. 1 <= r, R, H <= 100; 0 <= V <= 1000,000,000.

    3. r <= R.

    4. r, R, H, V are separated by ONE whitespace.

    5. There is NO empty line between two neighboring cases.

    输出

    For each test case, output the height of hot water on a single line. Please round it to six fractional digits.

    样例输入

    1100 100 100 3141562

    样例输出

    99.999024

    提示

     
     
     
     
    提说有两种方法 一种二分一种数学求法;
    下吗是数学求法:
     


    #include<stdio.h>
    #include<math.h>
    #define PI 3.14159265
    int main()
    {
    int t;
    double r,R,H,V,v0,h1;
    double ans;
    while(scanf("%d",&t)!=EOF)
    {
    while(t--)
    {
    scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
    if(r!=R)
    {
                    h1=(R-r)/(H*r)-H;                                             //补全的小圆锥A的高,用相似比算出来
                    v0=(PI*r*r*h1)/3;                                             //小圆锥A的体积
                   ans=(H+h1)-(H+h1)*pow((((PI*r*r*(H+h1)/3)-V)/(PI*r*r*(H+h1)/3)),1.0/3);     //热水倒入后的体积的高 可以用总的体积减去热血倒入后的体积形成的那个圆锥B与总的补起来后的大圆锥C用相似法比 得出小圆锥B的高   所求的高为大圆锥C高-小圆锥B的高
                    
    }
    else
    {
    ans=V/(PI*(r*r));
    }
    if(ans>H) ans=H;
    printf("%.6lf ",ans);
    }
    }
    return 0;
    }
    There are two ways of constructing a software design.One is to make it so simple that there are obviously no deficiencies;the other is to make it so complicated that there are no obvious deficiencies.
  • 相关阅读:
    .net的委托和事件的直接理解[转载]
    虚函数 多态 函数重载[转载]
    自动化 object <> xml
    用System.Web.HttpRequest模拟一个form的post
    【WP7】动画的使用
    【WP7】关于ListBox控件的数据绑定
    【WP7】坐标变换
    【WP7】页面之间数据交互
    【WP7】调用系统LED灯
    【WP7】MediaPlayer与关闭音乐的方法
  • 原文地址:https://www.cnblogs.com/yuanjunqq/p/5736248.html
Copyright © 2011-2022 走看看