zoukankan      html  css  js  c++  java
  • Uva 10815-Andy's First Dictionary(串)

    Problem B: Andy's First Dictionary

    Time limit: 3 seconds


    Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

    You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

    Input

    The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

    Output

    Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

    Sample Input

    Adventures in Disneyland
    
    Two blondes were going to Disneyland when they came to a fork in the
    road. The sign read: "Disneyland Left."
    
    So they went home.
    

    Sample Output

    a
    adventures
    blondes
    came
    disneyland
    fork
    going
    home
    in
    left
    read
    road
    sign
    so
    the
    they
    to
    two
    went
    were
    when
    给一篇文章。。然后生成一个字典。按字典序输出。。

    set乱搞

    #include <algorithm>
    #include <iostream>
    #include <cstring>
    #include <cstdlib>
    #include <string>
    #include <cctype>
    #include <vector>
    #include <cstdio>
    #include <cmath>
    #include <queue>
    #include <stack>
    #include <map>
    #include <set>
    #define ll long long
    #define maxn 360
    #define pp pair<int,int>
    #define INF 0x3f3f3f3f
    #define max(x,y) ( ((x) > (y)) ? (x) : (y) )
    #define min(x,y) ( ((x) > (y)) ? (y) : (x) )
    using namespace std;
    char t[210],tem[210];
    int main()
    {
    	set <string> s;
    	while (gets(t))
    	{
    		int len=strlen(t),p;
    		for(int i=0;i<=len;)
    		{
    			if(isalpha(t[i]))
    			{
    				p=0;
    				tem[p++]=tolower(t[i]);
    				i++;
    				while(isalpha(t[i]))
    				tem[p++]=tolower(t[i++]);
    				tem[p++]='';string x(tem);s.insert(x);
    			}
    			else
    			i++;
    		}
    	}
    	set <string>::iterator it=s.begin();
    	while(it!=s.end())
    	{
    		cout<<*it<<endl;
    		it++;
    	}
    	return 0;
    }
  • 相关阅读:
    Zabbix 单位换算
    Confluence6.9配置邮件服务器
    Linux内核基础优化
    Nginx跨域问题
    ssh远程登录过程中卡住
    postfix无法启动问题
    mysql-配置文件详解
    Mongodb-副本集部署
    Mongodb-安全配置优化
    Mongodb-简单部署
  • 原文地址:https://www.cnblogs.com/yutingliuyl/p/6719763.html
Copyright © 2011-2022 走看看