zoukankan      html  css  js  c++  java
  • POJ 3087 Shuffle'm Up(模拟退火)

    Description

    A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

    The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

    The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

    After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

    For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

    Input

    The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

    Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

    Output

    Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

    Sample Input

    2
    4
    AHAH
    HAHA
    HHAAAAHH
    3
    CDE
    CDE
    EEDDCC

    Sample Output

    1 2
    2 -1

    依照要求模拟一遍。注意分配的顺序。

    模拟退火呀

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<limits.h>
    #include<map>
    using namespace std;
    char s1[110],s2[110];
    char s[110*2];
    int n,c;
    
    int main()
    {
        cin>>n;
        for(int t=1;t<=n;t++)
        {
            cin>>c>>s1>>s2>>s;
            map<string,bool>visit;//标志映射
            visit[s]=true;
            int step=0;
            while(true)
            {
               char str[110*2];
               int len=0;
               for(int i=0;i<c;i++)
               {
                str[len++]=s2[i];
                str[len++]=s1[i];
               }
               str[len]='';
               step++;
               if(!strcmp(str,s))
               {
                   cout<<t<<" "<<step<<endl;
                   break;
               }
               else if(visit[str]&&strcmp(str,s))//出现过但又不是目标状态退出
               {
                   cout<<t<<" "<<-1<<endl;
                   break;
               }
               visit[str]=true;
               for(int i=0;i<c;i++)
                   s1[i]=str[i];//发s1
               s1[c]='';
               for(int i=c,k=0;i<2*c;i++)
                   s2[k++]=str[i];//发s2
               s2[c]='';
            }
        }
        return 0;
    }


  • 相关阅读:
    【JAVA零基础入门系列】Day13 Java类的继承与多态
    【JAVA零基础入门系列】Day12 Java类的简单应用
    【JAVA零基础入门系列】Day11 Java中的类和对象
    【JAVA零基础入门系列】Day10 Java中的数组
    【JAVA零基础入门系列】Day9 Java中的那个大数值
    【JAVA零基础入门系列】Day8 Java的控制流程
    【JAVA零基础入门系列】Day7 Java输入与输出
    【JAVA零基础入门系列】Day6 Java字符串
    【JAVA零基础入门系列】Day5 Java中的运算符
    【JAVA零基础入门系列】Day4 变量与常量
  • 原文地址:https://www.cnblogs.com/yutingliuyl/p/6733278.html
Copyright © 2011-2022 走看看