zoukankan      html  css  js  c++  java
  • 线段树专题(更新中。。。)

    Buy Tickets
    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 11102   Accepted: 5417

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i  N). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    最近一直在搞线段树,但是发现效率不高,做题技巧不足啊,,,,,,还是有待学习啊!

    ps:http://poj.org/problem?id=2828

     

     

    /* 题意:n个人陆续到一个队列排队,但是有的人可能会插队,题目给出第i个人插在pos[i]的位置,问最后队列的情况如何。

    思路 : 建一棵(1,n)的线段树,每个节点的值表示该区间的空位,从最后一个人往前插,

       这样pos的意义就成了插入是他前面有几个空位。具体实现看代码吧w */

    //单节点更新
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    #define lson l,mid,rt<<1
    #define rson mid+1,r,rt<<1|1
    
    using namespace std;
    
    int n,ans[200010],s[200010],t[200010],id;
    
    struct node
    {
        int l;
        int r;
        int num;
    } a[10000030];
    
    void build(int l,int r,int rt)
    {
        a[rt].l=l;
        a[rt].r=r;
        a[rt].num=r-l+1;//存这一层数的总个数
        if(l==r)
            return ;//结束的忘了,,,靠!
        int mid=(l+r)>>1;
        build(lson);
        build(rson);
    
    }
    
    void update(int rt,int x)
    {
        a[rt].num--;
        if(a[rt].l==a[rt].r)
        {
            id=a[rt].l;
            return ;
        }
        if(a[rt<<1].num>=x)//左子树的数字足够,则走左子树
            update(rt<<1,x);
        else//否则走右子树,并且将子树视为新树,编号从1开始
            update(rt<<1|1,x-a[rt<<1].num);
    }
    
    int main()
    {
        int i,j;
        while(scanf("%d",&n)!=EOF)
        {
            for(i=1;i<=n;i++)
                scanf("%d%d",&s[i],&t[i]);
            build(1,n,1);
            for(i=n;i>=1;i--)//从最后一个下手,反推之
            {
                update(1,s[i]+1);
                ans[id]=t[i];
            }
            for(i=1;i<=n;i++)
                printf("%d%c",ans[i],i==n?'
    ':' ');//很好的输出方式,可以借鉴!
        }
        return 0;
    }

    线段树单节点更新,终于有点小思路了。

    接下来,我会继续更新线段树的题目的,,,,,,奋斗啊

     
     
     
  • 相关阅读:
    IE8中li添加float属性,中英数字混合BUG
    jQuery ajax get与post后台交互中的奥秘
    BZOJ 4816 数字表格
    BZOJ 1598 牛跑步
    BZOJ 4077 Messenger
    相关分析 BZOJ 4821
    Crash的数字表格 BZOJ 2154 / jzptab BZOJ 2693
    回文串 BZOJ 3676
    古代猪文 BZOJ 1951
    树上的路径 BZOJ 3784
  • 原文地址:https://www.cnblogs.com/yuyixingkong/p/3414888.html
Copyright © 2011-2022 走看看