zoukankan      html  css  js  c++  java
  • HDU 1789 Doing Homework again (贪心)

    Doing Homework again

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6441    Accepted Submission(s): 3829



    Problem Description
    Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
    Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
     

    Output
    For each test case, you should output the smallest total reduced score, one line per test case.
     

    Sample Input
    3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
     

    Sample Output
    0 3 5
     
    题目大意:给定一系列任务的截至时间 和无法完毕的罚分
    解题思路:第N天截至的仅仅能在前N天完毕 对于第N天截至的任务 最多仅仅能有N个
    超出的必定无法完毕 所以对于第N天截至的任务 假设超过N个 那么保留前N大的
    后面的必定要罚分 然后从最后一天開始 全部截至日期大于当天的中的罚分最多的任务在当天完毕
    剩下的继续在下一天继续比較 在開始的时候记录总是罚分cur  用cur减去每次完毕的任务的罚分
    最后cur即是总是罚分
    先依照扣分从大到小排序,分数同样则依照截止日期从小到大排序。。
    然后按顺序,从截止日期開始往前找没有占用掉的时间。

    假设找不到了。则加到罚分里面
    代码:46MS
    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    #include <string.h>
    using namespace std;
    #define M 1000
    #define N 100
    struct node{
    int time,s;
    }dp[M];
    bool cmp(node x,node y)
    {
        if(x.s==y.s)
        return x.time<y.time;
        return x.s>y.s;
    }
    int map[M];
    int main()
    {
        int i,j,n,m;
        cin>>m;
        while(m--)
        {
            cin>>n;
            int cur=0;
            memset(map,0,sizeof(0));
            for(i=0;i<n;i++) cin>>dp[i].time;
            for(i=0;i<n;i++) cin>>dp[i].s;
            sort(dp,dp+n,cmp);
            memset(map,0,sizeof(map));
            for(i=0;i<n;i++)
            {
            for(j=dp[i].time;j>0;j--)
            {
              if(!map[j]) {map[j]=1;break;}
            }
            if(j==0) cur+=dp[i].s;
            }
            cout<<cur<<endl;
        }
        return 0;
    }
    

  • 相关阅读:
    Unity3D 4.0 界面 基础 入门
    try catch finally 用法
    Mysql表引擎Innodb、MyIsam、Memory
    初步的kudu+impala vs dorisdb vs tidb
    mysql创建类似oracle的dblink
    jedis请求keys超时报错
    php 1223
    php 1214
    php 1216
    php 1222
  • 原文地址:https://www.cnblogs.com/yxysuanfa/p/7195800.html
Copyright © 2011-2022 走看看