zoukankan      html  css  js  c++  java
  • hdu1171 灵活的运用背包问题咯。。。 还有!!!! 合理的计算数组的范围!! wa了好多次!

    Problem Description
    Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
    The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
    A test case starting with a negative integer terminates input and this test case is not to be processed.
     
    Output
    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
     
    Sample Input
    2 10 1 20 1 3 10 1 20 2 30 1 -1
     
    Sample Output
    20 10 40 40
    对于这种平均分配的问题 可以按照剩下的一半进行dp(在尽可能平均分配的情况下 a得多一些  那么 b就得在aver之下)
    由于这道题目用多重背包容易超内存。。  我这里在输入的时候做了处理 把重复的数一一写人数组 然后 数组的大小就计算失误了。。。。(多留点心眼)
     
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    using namespace std;
    int max(int x,int y)
    {
     if(x>y) return x;
     else return y;
    }
    int main()
    {
     int n,a[5551],dp[250005],i,j,z,sum,aver,suma,sumb,k;/////   两个数组的范围啊 好好计算。。
    // int fun;//dui geshu dayu 1 d chuli
        while(cin>>n)
        {
         if(n<0) break;
         sum=0;
         for(i=1;i<=n;i++)
         {
          scanf("%d %d",&a[i],&z);
          if(z>=2)
          {
           for(j=1;j<=z;j++)
           {
            a[i+1]=a[i++];
            n++;
           }
          }
          sum+=a[i]*z;
         }
         memset(dp,0,sizeof(dp));
         aver=sum/2;
         for(i=1;i<=n;i++)
         {
          for(j=aver;j>=a[i];j--)
          {
                 dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
          }
         }
         sumb=dp[aver];
         suma=sum-sumb;
         cout<<suma<<' '<<sumb<<endl;
        }
     return 0;
    }
     
  • 相关阅读:
    hdu 3068 最长回文
    Educational Codeforces Round 1 C. Nearest vectors
    Educational Codeforces Round 6 C. Pearls in a Row
    poj 3304 Segments
    Toy Storage
    poj 2318 TOYS
    CFA二级中文精讲(第2版)
    探秘大香格里拉
    巴西:热辣里约
    巴西:性感圣保罗
  • 原文地址:https://www.cnblogs.com/z1141000271/p/5384322.html
Copyright © 2011-2022 走看看