zoukankan      html  css  js  c++  java
  • L1-023. 输出GPLT

    L1-023. 输出GPLT

     

    给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT....”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

    输入格式:

    输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

    输出格式:

    在一行中按题目要求输出排序后的字符串。题目保证输出非空。

    输入样例:
    pcTclnGloRgLrtLhgljkLhGFauPewSKgt
    
    输出样例:
    GPLTGPLTGLTGLGLL
    思路:好奇当初是怎么做不出这题的
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int main()
    {
        char a[10000];
        gets(a);
        int G = 0, P = 0, L = 0, T = 0;
        for (int i = 0; a[i] != ''; i++)
        {
            if (a[i] == 'G' || a[i] == 'g')
            {    G++; continue;        }
            if (a[i] == 'P' || a[i] == 'p')
            {    P++; continue;        }
            if (a[i] == 'L' || a[i] == 'l')
            {    L++; continue;        }
            if (a[i] == 'T' || a[i] == 't')
            {    T++; continue;        }
        }
        
        while (G || P || L || T){
            if (G != 0){ putchar('G'); G--;}
            if (P != 0){ putchar('P'); P--; }
            if (L != 0){ putchar('L'); L--; }
            if (T != 0){ putchar('T'); T--; }
        }
        cout << endl;
        return 0;
    }
     
  • 相关阅读:
    StatefulSet分段更新
    StatefulSet更新策略
    Deployment的伸缩扩容
    Deployment的暂停和恢复
    Deployment回滚
    Deployment更新
    Deployment
    Prestop之sleep 90不生效
    kubernetes coredns服务异常解决
    calico/node is not ready: BIRD is not ready: BGP not established with xxxxx
  • 原文地址:https://www.cnblogs.com/zengguoqiang/p/8574975.html
Copyright © 2011-2022 走看看