zoukankan      html  css  js  c++  java
  • HDU 1075 What Are You Talking About (strings)

    What Are You Talking About

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 15966    Accepted Submission(s): 5177


    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
     

    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab(' '), enter(' ') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
     

    Output
    In this problem, you have to output the translation of the history book.
     

    Sample Input
    START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
     

    Sample Output
    hello, i'm from mars. i like earth!
    Hint
    Huge input, scanf is recommended.



    解析:将词典存在map中,然后对于history中的每一个词都查找能否在词典中找到,若能找到。则替换之;若没有,则直接输出。




    AC代码:

    #include <bits/stdc++.h>
    using namespace std;
    
    map<string, string> m;
    
    int main(){
        #ifdef sxk
            freopen("in.txt", "r", stdin);
        #endif // sxk
    
        string s, ss;
        cin>>s;
        while(cin>>s){
            if(s == "END") break;
            cin>>ss;
            m[ss] = s;
        }
        cin>>s;
        getchar();
        ss = "";
        while(getline(cin, s)){
            if(s[0] == 'E' && s[1] == 'N' && s[2] == 'D') break;
            int n = s.size();
            for(int i=0; i<n; ){
                while(i < n && isalpha(s[i]) && s[i] != ' ') ss += s[i ++];
                if(ss == ""){ cout<<s[i ++]; continue; }
                if(m.count(ss)) cout<<m[ss];
                else cout<<ss;
                ss = "";
            }
            puts("");
        }
        return 0;
    }
    



  • 相关阅读:
    无法识别的属性“targetFramework”的解决方法
    你所不知道的SQL Server数据库启动过程,以及启动不起来的各种问题的分析及解决技巧(转)
    win7系统如何安装SQL Server 2005
    2017年需要知道的技术
    平时对Vue的总结
    用rem实现h5页面的编写
    判断页面是横屏还是竖屏
    页面中插入视频兼容ie8以上的浏览器
    jquery实现加载更多效果
    联动选择通过ajax获取选择对应的数据
  • 原文地址:https://www.cnblogs.com/zfyouxi/p/5401725.html
Copyright © 2011-2022 走看看