zoukankan      html  css  js  c++  java
  • hdu-5655 CA Loves Stick(水题)

    题目链接:

    CA Loves Stick

    Time Limit: 2000/1000 MS (Java/Others)  

      Memory Limit: 262144/262144 K (Java/Others)


    Problem Description
     
    CA loves to play with sticks.
    One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
    (What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
     
    Input
     
    First line contains T denoting the number of testcases.
    T testcases follow. Each testcase contains four integers a,b,c,d in a line, denoting the length of sticks.
    1T1000, 0a,b,c,d2631
     
    Output
     
    For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
     
    Sample Input
    2
    1 1 1 1
    1 1 9 2
     
    Sample Output
    Yes
    No
     
    题意:
     
    给4条边,问能不能形成四边形;
     
    思路:
     
    三条边的和大于第四边就能形成,主要是和会爆long long 所以要做差;还要注意是0的情况;
     
    AC代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    long long a[5];
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            for(int i=0;i<4;i++)
            {
                cin>>a[i];
            }
            sort(a,a+4);
            if(a[0]==0)cout<<"No"<<endl;
            else {
            if(a[3]-a[0]-a[1]<a[2])cout<<"Yes"<<"
    ";
            else cout<<"No"<<"
    ";
            }
    
        }
        return 0;
    }
     
  • 相关阅读:
    Python 内置函数 —— format
    命名集 —— 名字结构
    命名集 —— 名字结构
    存储与主板的外设接口
    存储与主板的外设接口
    验证码的认识
    验证码的认识
    windows 路径
    windows 路径
    极限的求法
  • 原文地址:https://www.cnblogs.com/zhangchengc919/p/5348409.html
Copyright © 2011-2022 走看看