zoukankan      html  css  js  c++  java
  • 1120 Friend Numbers (20 分)set的使用

    1120 Friend Numbers (20 分)

    Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104​​.

    Output Specification:

    For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

    Sample Input:

    8
    123 899 51 998 27 33 36 12
    

    Sample Output:

    4
    3 6 9 26
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    using namespace std;
    
    
    
    int main()
    {
        int n;
        cin>>n;
        string str;
        set<int> num;
        for(int i=0;i<n;i++)
        {
            cin>>str;
            int sum=0;
            for(int j=0;j<str.size();j++)
            {
                sum+=str[j]-'0';
            }
            num.insert(sum);
        }
        cout<<num.size()<<endl;
        cout<<*(num.begin());
        //num.erase(*(num.begin()));
        for(auto t=++num.begin();t!=num.end();t++)
        {
            cout<<" "<<*t;
        }
        return 0;
    }

      
  • 相关阅读:
    Redis配置文件的使用
    WEB请求处理一:浏览器请求发起处理
    Nginx配置文件(nginx.conf)配置详解
    【node】------mongoose的基本使用
    Promise.resolve()与new Promise(r => r(v))
    promise是什么?
    apiDoc
    apiDoc 使用指南
    微信小程序-性能与体验优化
    微信小程序-调取上一页的方法
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10303584.html
Copyright © 2011-2022 走看看