zoukankan      html  css  js  c++  java
  • 1090 Highest Price in Supply Chain (25 分)

    1090 Highest Price in Supply Chain (25 分)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

    Input Specification:

    Each input file contains one test case. For each case, The first line contains three positive numbers: N (105​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si​​ is the index of the supplier for the i-th member. Sroot​​ for the root supplier is defined to be 1. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010​​.

    Sample Input:

    9 1.80 1.00
    1 5 4 4 -1 4 5 3 6
    

    Sample Output:

    1.85 2

    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    #include<stack>
    #include<string.h>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    
    vector<vector<int>>graph;
    int maxDepth=0;
    int cnt=0;
    
    void dfs(int id,int depth)
    {
        if(graph[id].size()==0)
        {
            if(depth==maxDepth)
                cnt++;
            else if(depth>maxDepth)
            {
                maxDepth=depth;
                cnt=1;
            }
        }
        for(auto num:graph[id])
        {
            dfs(num,depth+1);
        }
    }
    
    int main()
    {
        int n;
        double p,r;
        cin>>n>>p>>r;
        graph.resize(n+1);
        int root=0;
        for(int i=0;i<n;i++)
        {
            int temp;
            cin>>temp;
            if(temp==-1)
            {
                root=i;
                continue;
            }
            graph[temp].push_back(i);
        }
        dfs(root,0);
        //cout<<maxDepth<<endl;
        printf("%.2f %d",p*pow(1+r/100,maxDepth),cnt);
    
        return 0;
    }
  • 相关阅读:
    解决ScrollView嵌到listView冲突问题
    Popupwindow 的简单实用,(显示在控件下方)
    BroadCast,BroadCastReceiver
    NSURLSession
    sirikit
    MJExtension使用
    iOS中的translucent和automaticallyAdjustsScrollViewInsets用法
    如何获取LanuchImage-1(详细)
    如何获取LanuchImage
    MJRefresh详解
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10324644.html
Copyright © 2011-2022 走看看