zoukankan      html  css  js  c++  java
  • Hdu 1059 Dividing

    Dividing

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 25912    Accepted Submission(s): 7421

    Problem Description

    Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
    Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

    Input

    Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

    The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

    Output

    For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

    Output a blank line after each test case.

    Sample Input

    1 0 1 2 0 0

    1 0 0 0 1 1

    0 0 0 0 0 0

    Sample Output

    Collection #1:

    Can't be divided.

    Collection #2:

    Can be divided.

    #include<string.h>
    #include<stdio.h>int a[7];
    int f[120005];
    int v,k;
    void ZeroOnePack(int cost,int weight)
    {
        for(int i=v;i>=cost;i--)
            if(f[i]<f[i-cost]+weight)
                f[i]=f[i-cost]+weight;
    }
    void ComplementPack(int cost,int weight)
    {
        for(int i=cost;i<=v;i++)
            if(f[i]<f[i-cost]+weight)
                f[i]=f[i-cost]+weight;    
    }
    void MutiplePack(int cost ,int weight,int amount)
    {
        if(cost*amount>=v)
            ComplementPack(cost,weight);
        else
        {
            for(int k=1;k<amount;k++)
            {
                ZeroOnePack(k*cost,k*weight);
                amount-=k;
                k=k*2;
            }
            ZeroOnePack(amount*cost,amount*weight);
        }
    }
    int main()
    {
        int tol;
        int icase=0;
        while(1)
        {
            icase++;
            tol=0;
            for(int i=1;i<7;i++)
            {
                scanf("%d",&a[i]);
                tol    +=a[i]*i;
            }
            if(tol==0)break;
            if(tol%2==1)
            {
                printf("Collection #%d:
    Can't be divided.
    
    ",icase);
                continue;
            }
            else
            {
                v=tol/2;
                memset(f,0,sizeof(f));
                for(int i=1;i<7;i++)
                    MutiplePack(i,i,a[i]);
                if(f[v]==v)
                    printf("Collection #%d:
    Can be divided.
    
    ",icase);
                else
                    printf("Collection #%d:
    Can't be divided.
    
    ",icase);
            }
                
        }
        return 0;
    }
    

      

  • 相关阅读:
    Murano Weekly Meeting 2016.05.24
    Murano Weekly Meeting 2016.05.17
    Murano Weekly Meeting 2016.05.10
    python3.4 x86_64-linux-gnu-gcc Error
    初学makefile
    解决Spring JdbcTemplate调用queryForObject()方法结果集为空时报异常
    svn命令行使用
    jquery选中checkbox
    jstl core and jstl fn
    linux上的shutdown命令
  • 原文地址:https://www.cnblogs.com/zhangliu/p/7057835.html
Copyright © 2011-2022 走看看