zoukankan      html  css  js  c++  java
  • nyoj1008 Elevator

    Elevator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24439    Accepted Submission(s): 13116


    Problem Description
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
     
    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
     
    Output
    Print the total time on a single line for each test case. 
     
    Sample Input
    1 2 3 2 3 1 0
     
    Sample Output
    17 41
     
    View Code
    #include <stdio.h>
    int main()
    {
        int floor,number,sum,i,n;
        while(scanf("%d",&n)!=EOF&&n)
        {
            floor=0;
                sum=0;
    
            for(i=0;i<n;i++)
            {
                
                scanf("%d",&number);
                if(number>floor)
                {
                    sum+=(number-floor)*6;
                    sum+=5;
                }
                else
                {
                    sum+=(floor-number)*4;
                    sum+=5;
                }
                floor=number;
            }
            printf("%d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    Class类
    HTML表单格式化
    HTML表单组件
    html常用标签
    Html概述
    Myeclipse2016安装Aptana
    长元音
    对比法记音标
    Java基础八--构造函数
    WPS2012交叉引用技巧,word比wps这点强更新參考文献
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_05_29.html
Copyright © 2011-2022 走看看