zoukankan      html  css  js  c++  java
  • HDUOJ1005Number Sequence

    Number Sequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 61101    Accepted Submission(s): 13923


    Problem Description
    A number sequence is defined as follows:

    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

    Given A, B, and n, you are to calculate the value of f(n).
     
    Input
    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
     
    Output
    For each test case, print the value of f(n) on a single line.
     
    Sample Input
    1 1 3 1 2 10 0 0 0
     
    Sample Output
    2 5
     
    View Code
    #include<stdio.h>
    #include<string.h>
    int str[200];
    int main()
    {
        int i,n,a,b,k;
        while(scanf("%d %d %d",&a,&b,&n)&&(a||b||n))
        {
            memset(str,0,sizeof(str));
            str[0]=1,str[1]=1;
            for(i=2;i<200;i++)
            {
                str[i]=(a*str[i-1]+b*str[i-2])%7;
                //printf("str[%d]=%d",i,str[i]);//
                if(str[i]==1&&str[i]==str[i-1])
                {   //k=i;
                   //printf("i=%d k==%d",i,k);
                      break;
                }
            }
            printf("%d\n",str[(n-1)%(i-1)]);
        }
        return 0;
    }
  • 相关阅读:
    校门外的树
    年龄与疾病
    数组逆序重放
    计算书费
    陶陶摘苹果
    与指定数字相同的数的个数
    上学路线
    NOIP2011 普及組 統計單詞數
    [HAOI2012]音量调节
    [USACO11JAN]利润Profits
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_07_25.html
Copyright © 2011-2022 走看看