zoukankan      html  css  js  c++  java
  • HDUOJ 2636 Electrical Outlets

    Electrical Outlets

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7456   Accepted: 5699

    Description

    Roy has just moved into a new apartment. Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy's apartment has only one single wall outlet, so Roy can only power one of his electrical appliances at a time. 
    Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time. The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now. 
    Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered itself to be of any use.

    Input

    Input will start with a single integer 1 <= N <= 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 <= K <= 10, indicating the number of power strips in the test case. Then follow, on the same line, K integers separated by single spaces, O1 O2 . . . OK, where 2 <= Oi <= 10, indicating the number of outlets in each power strip.

    Output

    Output one line per test case, with the maximum number of appliances that can be powered.

    Sample Input

    3
    3 2 3 4
    10 4 4 4 4 4 4 4 4 4 4
    4 10 10 10 10

    Sample Output

    7
    31
    37
    View Code
    #include<stdio.h>
    int main()
    {
        int i,n,m,t,sum;
        scanf("%d",&n);
        while(n--)
        {
          sum=0;
          scanf("%d",&m);
          for(i=0;i<m;i++)
          {
            scanf("%d",&t);
            sum+=t;
          }
          sum-=m-1;
          printf("%d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    Jquery动画第二部分
    Jquery动画第一部分
    Datalist增删改查——联系人管理
    Access增删改查 (持续更新中)
    Webform——Repeater多表联合显示
    Webform——内嵌word编辑器
    DataGridView导出Excel
    《Linux内核设计与实现》读书笔记(十三)- 虚拟文件系统
    《Linux内核设计与实现》读书笔记(十二)- 内存管理
    《Linux内核设计与实现》读书笔记(十一)- 定时器和时间管理
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_07_250.html
Copyright © 2011-2022 走看看