zoukankan      html  css  js  c++  java
  • POJ 1004 Financial Management

    Financial Management
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 186714   Accepted: 70910

    Description

    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

    Input

    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

    Output

    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

    Sample Input

    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75

    Sample Output

    $1581.42

    此题太水!
    AC代码:
    Source Code
    Problem: 1004		User: zhaopeng938
    Memory: 288K		Time: 0MS
    Language: C++		Result: Accepted
    
    Source Code
    
    #include<iostream>
    #include<iomanip>
    //#include<fstream>
    using namespace std;
    int main()
    {
        //ifstream in("test.txt");
        double ave;
        double sum=0;
        for(int i=0;i<12;i++)
        {
        	cin>>ave;
        	sum+=ave;
        }
        ave=sum/12;
        cout<<'$'<<setiosflags(ios::fixed)<<setprecision(2)<<ave;
        return 0;
    }
    


  • 相关阅读:
    phpcs
    asp.net之cookie
    ajax技术
    union、except和intersect查询
    外连接查询
    对查询结果分组
    聚合函数查询
    数据库的约束
    数据库备份
    fusionCharts
  • 原文地址:https://www.cnblogs.com/zhaopeng938/p/7550664.html
Copyright © 2011-2022 走看看