zoukankan      html  css  js  c++  java
  • bzoj1648 [Usaco2006 Dec]Cow Picnic 奶牛野餐

    Description

    The cows are having a picnic! Each of Farmer John's K (1 <= K <= 100) cows is grazing in one of N (1 <= N <= 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 <= M <= 10,000) one-way paths (no path connects a pasture to itself). The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

      K(1≤K≤100)只奶牛分散在N(1≤N≤1000)个牧场.现在她们要集中起来进餐.牧场之间有M(1≤M≤10000)条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方.那么,有多少这样的牧场呢?

    Input

    * Line 1: Three space-separated integers, respectively: K, N, and M * Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing. * Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.

     1行输入KNM.接下来K行,每行一个整数表示一只奶牛所在的牧场编号.接下来M行,每行两个整数,表示一条有向路的起点和终点

    Output

    * Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

        所有奶牛都可到达的牧场个数

    Sample Input

    2 4 4
    2
    3
    1 2
    1 4
    2 3
    3 4


    INPUT DETAILS:

    4<--3
    ^ ^
    | |
    | |
    1-->2

    The pastures are laid out as shown above, with cows in pastures 2 and 3.

    Sample Output

    2

    牧场3,4是这样的牧场.

    对于给定的每一只牛,从它的位置作dfs,所有能到的点的visit[k]++,最后判断有多少个visit[i]==k

    #include<cstdio>
    #include<cstring>
    struct edge{
    	int to,next;
    }e[20010];
    bool mrk[1010];
    int k,n,m,cnt,ans;
    int head[1010],cow[110],visit[1010];
    inline void ins(int u,int v)
    {
    	e[++cnt].to=v;
    	e[cnt].next=head[u];
    	head[u]=cnt;
    }
    inline void dfs(int x)
    {
    	mrk[x]=1;visit[x]++;
    	for (int i=head[x];i;i=e[i].next)
    	  if (!mrk[e[i].to])dfs(e[i].to);
    }
    int main()
    {
    	scanf("%d%d%d",&k,&n,&m);
    	for (int i=1;i<=k;i++)
    	  scanf("%d",&cow[i]);
    	int x,y;
    	for (int i=1;i<=m;i++)
    	  {
    	  	scanf("%d%d",&x,&y);
    	  	ins(x,y);
    	  }
    	for(int i=1;i<=k;i++) 
    	{
    	  memset(mrk,0,sizeof(mrk));
    	  dfs(cow[i]);
    	}
    	for(int i=1;i<=n;i++)
    	  if (visit[i]==k) ans++;
    	printf("%d",ans);
    }


    ——by zhber,转载请注明来源
  • 相关阅读:
    浮点型float
    Linux时间同步命令
    四层负载均衡和七层负载均衡的区别
    Linux下把Mysql和Apache加入到系统服务里
    Linux下Nagios的安装与配置
    Linux是怎么启动的(整理)
    centos 双网卡 eth0 eth1 配置
    MYSQL的常用命令和增删改查语句和数据类型
    CentOS 下如何修改 MySQL 的密码
    mysql unrecognized service问题解决
  • 原文地址:https://www.cnblogs.com/zhber/p/4035940.html
Copyright © 2011-2022 走看看