zoukankan      html  css  js  c++  java
  • bzoj2102 [Usaco2010 Dec]The Trough Game

    Description

    Farmer John and Bessie are playing games again. This one has to do with troughs of water. Farmer John has hidden N (1 <= N <= 20) troughs behind the barn, and has filled some of them with food. Bessie has asked M (1 <= M <= 100) questions of the form, "How many troughs from this list (which she recites) are filled?". Bessie needs your help to deduce which troughs are actually filled. Consider an example with four troughs where Bessie has asked these questions (and received the indicated answers): 1) "How many of these troughs are filled: trough 1" --> 1 trough is filled 2) "How many of these troughs are filled: troughs 2 and 3" --> 1 trough is filled 3) "How many of these troughs are filled: troughs 1 and 4" --> 1 trough is filled 4) "How many of these troughs are filled: troughs 3 and 4" --> 1 trough is filled From question 1, we know trough 1 is filled. From question 3, we then know trough 4 is empty. From question 4, we then know that trough 3 is filled. From question 2, we then know that trough 2 is empty. 求N位二进制数X,使得给定的M个数,满足X and Bi=Ci ,Bi ci分别是读入的两个数

    Input

    * Line 1: Two space-separated integers: N and M * Lines 2..M+1: A subset of troughs, specified as a sequence of contiguous N 0's and 1's, followed by a single integer that is the number of troughs in the specified subset that are filled.

    Output

    * Line 1: A single line with: * The string "IMPOSSIBLE" if there is no possible set of filled troughs compatible with Farmer John's answers. * The string "NOT UNIQUE" if Bessie cannot determine from the given data exactly what troughs are filled. * Otherwise, a sequence of contiguous N 0's and 1's specifying which troughs are filled.

    Sample Input

    4 4
    1000 1
    0110 1
    1001 1
    0011 1

    Sample Output

    1010


    就是一很水的模拟啊……因为最多才2^20=100w所以直接暴力搞

    #include<cstdio>
    int n,m;
    int a[110][30];
    int x[110];
    int ans=-1;
    inline bool mrk(int num)
    {
    	for (int i=1;i<=m;i++)
    	{
    	 	int tot=0;
    		for (int j=1;j<=n;j++)
    	  	  if ( a[i][j] && (num/(1<<(n-j)))%2 )tot++;
    	  	if (tot!=x[i]) return 0;
    	}
    	return 1;
    }
    int main()
    {
    	scanf("%d%d",&n,&m);
    	for (int i=1;i<=m;i++)
    	{
    		for (int j=1;j<=n;j++)
    		{
    			char ch=getchar();
    			while (ch!='0'&&ch!='1')ch=getchar();
    			if(ch=='0')a[i][j]=0;
    			else a[i][j]=1;
    		}
    		scanf("%d",&x[i]);
    	}
    	for (int i=0;i<(1<<n);i++)
    	  {
    	 	if (mrk(i))
    	 	{
    	 		if (ans!=-1){printf("NOT UNIQUE");return 0;}
    	 		ans=i;
    	 	}
    	  }
    	if (ans!=-1)for (int j=n-1;j>=0;j--)printf("%d",(ans&(1<<j))/(1<<j));
    	else printf("IMPOSSIBLE");
    	return 0;
    }
    

      

    ——by zhber,转载请注明来源
  • 相关阅读:
    Windows常用命令
    Linux常用命令
    SpringBoot实现动态数据源切换及单库事务控制
    ArrayList与LinkedList
    java学习笔记之集合—ArrayList源码解析
    java学习笔记之反射—反射和工厂模式
    java学习笔记之反射—Class类实例化和对象的反射实例化
    java学习笔记之IO编程—对象序列化
    java学习笔记之IO编程—打印流和BufferedReader
    java学习笔记之IO编程—内存流、管道流、随机流
  • 原文地址:https://www.cnblogs.com/zhber/p/4035986.html
Copyright © 2011-2022 走看看