zoukankan      html  css  js  c++  java
  • A+B的三种输入输出

    A+B for Input-Output Practice (I)

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 62475    Accepted Submission(s): 35141

    Problem Description

    Your task is to Calculate a + b.
    Too easy?! Of course! I specially designed the problem for acm beginners.
    You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.

     

     

    Input

    The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

     

     

    Output

    For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

     

     

    Sample Input

    1 5

    10 20

     

     

    Sample Output

    6

    30

    /*#include<stdio.h>

    int main()

    {

        int a,b;

        while(scanf("%d%d",&a,&b)!=EOF)

        {

           printf("%d ",a+b);

                                       }

           return 0;

    }

    //第一种  没有说明几组数据的,要以  EOF 结束。 hdu 1089*/

    A+B for Input-Output Practice (II)

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 47296    Accepted Submission(s): 31462

    Problem Description

    Your task is to Calculate a + b.

     

     

    Input

    Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

     

     

    Output

    For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

     

     

    Sample Input

    2

    1 5

    10 20

     

     

    Sample Output

    6

    30

    *#include<stdio.h>

    int main()

    {

        int a,b,n;

        scanf("%d",&n);

        while(n--)

        {

                  scanf("%d%d",&a,&b);

                  printf("%d ",a+b);

        }

        return 0;

    } //第二种,输入一个整数,用一个循环(while或其他)来控制。 不要忘记加换行  “ ” hdu 1090

     

    A+B for Input-Output Practice (III)

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 56520    Accepted Submission(s): 29031

    Problem Description

    Your task is to Calculate a + b.

     

     

    Input

    Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

     

     

    Output

    For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

     

     

    Sample Input

    1 5

    10 20

    0 0

     

     

    Sample Output

    6

    30

     

    #include<stdio.h>

    int main()

    {

        int a,b;

        while(scanf("%d%d",&a,&b)&&(a!=0||b!=0))

        {

                                      printf("%d ",a+b);

        }

        return 0;

    }

    // 第三种,遇到输入a,b都为0的结束。注意输入是 判断 a b 是否为0  或’||‘和 ”&&“之间的区别。Hdu1091

  • 相关阅读:
    Jenkins Pipeline Script from SCM应用
    Jenkins获取所有job
    Jenkins pipeline使用git共享库(ShareLibrary)
    Jenkins获取用户所属组
    PowerShell函数当做变量传递给另一个函数
    Jenkins input获取提交人
    Groovy Map排序
    Jenkins Pipeline使用File parameter
    Jenkins Active Parameters之Groovy Script(获取具有管理员权限的组+组成员)
    Android中C/C++的日志打印
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3217129.html
Copyright © 2011-2022 走看看