zoukankan      html  css  js  c++  java
  • Let the Balloon Rise-hdu-1004

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 57677    Accepted Submission(s): 21082

    Problem Description

    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.

     

     

    Input

    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.

     

     

    Output

    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

     

     

    Sample Input

    5

    green

    red

    blue

    red

    red

    3

    pink

    orange

    pink

    0

     

     

    Sample Output

    red

    pink

    解题思路:1、用二维数组保存要输入的数据。2、然后用两个循环结构,把本身与其他的字符串作对比,一样的加一,并保存在对应的一维数组(int)里面。3、把2保存的数据比较大小,找出最大的即可。并且,最大数据的对应编号保存在变量(m)中。4、输出对应的字符串即可。

     

    /*#include<stdio.h>

    #include<string.h>

    int main()

    {

          int n,m,i,j,c[1200],k;

          char a[1200][20],b[20];

          while(scanf("%d",&n)&&n!=0)

          {

           memset(c,0,sizeof(c));

          for(i=0;i<n;i++)

          scanf("%s",a[i]);

          for(i=0;i<n;i++)

           {

            for(j=i;j<n;j++)

             {

               if(strcmp(a[i],a[j])==0)

                 c[i]++;

             }

           }

           for(i=0,m=k=0;i<1;i++)

            for(j=i+1;j<n;j++)

             {

               if(c[i]<c[j])

                  {k=j;c[i]=c[j];m=j;}

                  else

                  {k=m;}//想多了,想的有点复杂了。

             }

               //for(i=0;i<n;i++)

             printf("%s ",a[k]);

         }

         return 0;

    }

    */

    #include <stdio.h>

    #include <string.h>

    int main()

    {

        char a[10000][12];

        int n,m,i,j,t,b[10000];

        while (scanf("%d",&n),n)

        {

        for(i=0;i<n;i++)

         scanf("%s",&a[i]);

        for(i=0;i<n;i++)

        {

            b[i]=0;

            for(j=0;j<n;j++)

              {

                m=strcmp(a[i],a[j]);

                if(m==0)

                  b[i]++;

              }

        }

               t=b[0];

         for(i=0;i<n;i++)

            if(t<b[i])

            {

                t=b[i];

                m=i;

            }

            printf("%s ",a[m]);

        }

            return 0;

    }

  • 相关阅读:
    zsh: command not found: mysql
    ReactiveX -Rx
    mac 安装mysql
    mac 完全卸载mysql
    gradle 编译OutOfMemoryError
    Nginx均衡负载(IP_HASH)未生效
    Tomcat集群+Nginx+Redis服务搭建
    Spring之SpringMVC的RequestToViewNameTranslator(源码)分析
    Spring之SpringMVC的MethodNameResolver(源码)分析
    Spring之SpringMVC前端控制器DispatcherServlet(源码)分析
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3221261.html
Copyright © 2011-2022 走看看