zoukankan      html  css  js  c++  java
  • The Number of set-hdu-3006

    The Number of set

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 987    Accepted Submission(s): 617

    Problem Description

    Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.

     

     

    Input

    There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.

     

     

    Output

    For each case,the output contain only one integer,the number of the different sets you get.

     

     

    Sample Input

    4 4

    1 1

    1 2

    1 3

    1 4

    2 4

    3 1 2 3

    4 1 2 3 4

     

     

    Sample Output

    15

    2

    题目大意: 求给定的几个集合,能合并成多少集合,不能重复,不能删除集合中的元素。

    解题思路:

    1、  用二进制标记集合,如集合 1 2 3 被标记为 0111。集合1 3 4 则被标记为 1101;

    2、  所以求集合的并集,就是把被标记的进行或(|)运算。并把值记录下来。

    3、  查看总共有多少被记录下来的值,即有多少集合。

    程序代码:

    #include<stdio.h>

    #include<string.h>

    int main()

    {

        int n,m,k,t,i,j,b;

        int a[1<<15];                         //定义数组,二进制的数刚好15位

        while(scanf("%d %d",&n,&m)!=EOF)

        {

          j=0;

          memset(a,0,sizeof(a));

          while(n--)

           {

             b=0;

             scanf("%d",&k);

             while(k--)

              {

                scanf("%d",&t);

                b=b|(1<<(t-1));                //标记每个集合

              }

              a[b]=1;                        // 把被标记的数 记为真值1

              for(i=0;i<=(1<<14);i++)

               {

                 if(a[i])

                 a[i|b]=1;                   // 把被标记的 刚刚标记的集合 进行或运算。

               }

           }

          

           for(i=0;i<=(1<<14);i++)

           {

            if(a[i])

            j++;                      // 查看被标记的总数。

           }

           printf("%d ",j);

        }

        return 0; 

    }

  • 相关阅读:
    多重继承的构造函数和析构函数的执行顺序(包含虚基类)
    java解析XML之DOM解析和SAX解析(包含CDATA的问题)
    java解析XML之DOM解析和SAX解析(包含CDATA的问题)
    计算机网络总结之运输层
    Method, apparatus, and system for speculative abort control mechanisms
    [转]如何用adb控制MTKLogger
    反转单向、双向链表
    删除链表中间节点和a/b处的节点
    Android 中log 找到关键log
    在单链表和双链表中删除倒数第k个结点
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3233114.html
Copyright © 2011-2022 走看看