zoukankan      html  css  js  c++  java
  • poj-1363Rails

    Rails

    Time Limit: 1000MS

     

    Memory Limit: 10000K

    Total Submissions: 21555

     

    Accepted: 8612

    Description

    There is a famous railway station in PopPushCity. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

     


    The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

    Input

    The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

    The last block consists of just one line containing 0.

    Output

    The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

    Sample Input

    5

    1 2 3 4 5

    5 4 1 2 3

    0

    6

    6 5 4 3 2 1

    0

    0

    Sample Output

    Yes

    No

     

    Yes

    题目大意: 有一组数据 1 2 3 4 。。。。。。n   问是否能按照给的顺序输出,能的输出yes 不能的输出no。

    解题思路:

    1、  用栈模拟数字来解决。

    注意事项:

    2、  输出格式,第一个0 表示一次(只给出1个n,可能有多组测试数据)的测试数据结束,第二个0 才是这次程序运行的结束。

    程序代码:

    #include<stdio.h>

    #include<string.h>

    int main()

    {

        int a[1100],b[1100],n,m,i,atop,btop;

        while(scanf("%d",&n),n)

        {

           

            while(1)

            {

                memset(a,0,sizeof(a));

                memset(a,0,sizeof(a));

                scanf("%d",&a[0]);                 //输入第一个数据,

                if(a[0]==0)                       //第一个数据是 0, 则跳出

                break;

                for(i=1;i<n;i++)

                scanf("%d",&a[i]);                //数组a 存放要求输出的顺序

                btop=1;

                for(i=1,m=0;i<=n;i++)

                {

                    b[btop++]=i;                  //进栈是按照自然数的顺序进栈

                    while(btop>1&&m<=n&&b[btop-1]==a[m])         //栈顶的数 如果是要求输出的第一个数  则出站

                    {

                        m++;                                // 要求输出的数组加一

                        btop--;                             // 栈顶出去后 要记得减一

                       

                    }

                }

                if(m==n)                          // 最后如果已经出栈的数据  等于要求的总共数据 则输出yes

                printf("Yes ");

                else

                printf("No ");                   // 否则输出 no

            }

            printf(" ");

        }

        return 0;

    }

  • 相关阅读:
    洛谷 P3040 [USACO12JAN]贝尔分享Bale Share
    洛谷 P1994 有机物燃烧
    洛谷 P3692 [PUB1]夏幻的考试
    洛谷 P2117 小Z的矩阵
    洛谷 P1154 奶牛分厩
    洛谷 P1718 图形复原
    洛谷 P1900 自我数
    洛谷 P1964 【mc生存】卖东西
    洛谷 P1123 取数游戏
    hdu_2844_Coins(多重背包)
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3248620.html
Copyright © 2011-2022 走看看