zoukankan      html  css  js  c++  java
  • 4-圆数Round Numbers(数位dp)

                                                  Round Numbers
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 14947   Accepted: 6023

    Description

    The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

    They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
    otherwise the second cow wins.

    A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

    Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

    Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

    Input

    Line 1: Two space-separated integers, respectively Start and Finish.

    Output

    Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

    Sample Input

    2 12

    Sample Output

    6

    Source

    这题的约束就是一个数的二进制中0的数量要不能少于1的数量,通过上一题,这题状态就很简单了,dp[pos][num],到当前数位pos,0的数量减去1的数量不少于num的方案数,一个简单的问题,中间某个pos位上num可能为负数(这不一定是非法的,因为我还没枚举完嘛,只要最终的num>=0才能判合法,中途某个pos就不一定了),这里比较好处理,Hash嘛,(最小就-32吧(好像),直接加上32,把32当0用)。这题主要是要想讲一下lead的用法,显然我要统计0的数量,前导零是有影响的。至于!lead&&!limit才能dp,都是类似的,自己慢慢体会吧。
     
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    int dp[33][64]; //dp[i][j]表示i位数二进制0的个数比1的个数不低于的数的个数 
    int digit[33];  //二进制数的每一位 
    
    int dfs(int pos, int sum, int lead, int limit){
    	    //    i,    j, 是否有前导0, 取值是否受限 
    	    //sum即j表示0比1多的个数 
    	if(pos <= 0){
    		return sum >= 0;
    	}
    	if(!lead && !limit && dp[pos][sum] != -1){
    		return dp[pos][sum];
    	}
    	int rt = 0;
    	int end = limit ? digit[pos] : 1;
    	for(int i = 0; i <= end; i++){
    		if(lead && i == 0){ //有前置0并且当前数位位0,则此0不计数,sum不变 
    			rt += dfs(pos - 1, sum, lead, limit && i == end);
    		}
    		else{
    			rt += dfs(pos - 1, sum + (i ? -1 : 1), lead && i == 0, limit && i == end);
    		}
    	}
    	if(!limit && !lead){
    		dp[pos][sum] = rt;
    	}
    	return rt;
    } 
    
    int solve(int x){
    	int len = 0;
    	while(x){
    		digit[++len] = x & 1;
    		x = x >> 1;
    	}
    	return dfs(len, 0, 1, 1);
    }
    
    int main(){
    	int n, m;
    	memset(dp, -1, sizeof(dp));
    	
    	cin >> n >> m;
    	cout << solve(m) - solve(n - 1) << endl; 
    	
    	return 0;
    }
     
    

      

  • 相关阅读:
    [C++ Primer Plus] 第9章、内存模型和名称空间(二)课后习题
    [C++ Primer Plus] 第9章、内存模型和名称空间(一)程序清单
    [c/c++] programming之路(28)、结构体存储和内存对齐+枚举类型+typedef+深拷贝和浅拷贝
    [c/c++] programming之路(27)、union共用体
    [c/c++] programming之路(26)、结构体
    opencv学习之路(37)、运动物体检测(二)
    [Python]基础教程(4)、Python 变量类型
    opencv学习之路(36)、运动物体检测(一)
    opencv学习之路(35)、SURF特征点提取与匹配(三)
    opencv学习之路(34)、SIFT特征匹配(二)
  • 原文地址:https://www.cnblogs.com/zhumengdexiaobai/p/8391531.html
Copyright © 2011-2022 走看看