zoukankan      html  css  js  c++  java
  • UVA10391

    题意:给定单词集合S,包含若干单词,找出S中所有满足这样条件的元素p:p==str1+str2 && str1属于S && str2属于S
    解法:暴力搜;或者用set的查找函数

    You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

    Input

    Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

    Output

    Your output should contain all the compound words, one per line, in alphabetical order.

    Sample Input

    a alien born less lien never nevertheless new newborn the zebra

     

    Sample Output

    alien newborn


    set的搜索:
    #include<iostream>
    #include<set>
    using namespace std;

    int main() {
        set<string> s;
        string tmp;
        while (cin >> tmp)
            s.insert(tmp);
        set<string>::iterator it = s.begin();
        for (it; it != s.end(); it++) {
            tmp = *it;
            for (int i = 1; i < tmp.length(); i++) {
                if (s.find(tmp.substr(0, i)) != s.end() && s.find(tmp.substr(i, tmp.length() - i)) != s.end()) {
                    cout << tmp << endl;
                    break;
                }
            }
        }
        return 0;
    }

    暴力搜:
    #include <iostream>
    #include <string>
    #include <vector>
    #include <algorithm>
    using namespace std;
    int main(){
        //    freopen("in.txt","r",stdin);
        vector<string>vs[26];
        string s;
        while(getline(cin,s))
            if(s.length())vs[s[0]-'a'].push_back(s);
        for(int i=0; i<26; i++){
            if(vs[i].size()>=2){
                for(int j=1; j<vs[i].size(); j++){
                    bool judge = true;
                    for(int k=0; k<j; k++){
                        if(vs[i][j].find(vs[i][k])==0){
                            string t = vs[i][j].substr(vs[i][k].length());
                            if(!vs[t[0]-'a'].empty()){
                                for(int z=0; z<vs[t[0]-'a'].size(); z++){
                                    if(vs[t[0]-'a'][z]==t){
                                        if(judge)cout << vs[i][j] << endl;
                                        judge = false;
                                    }
                                }
                            }
                        }
                    }
                }
            }
        }
        return 0;
    }


    找到单词后注意标记,保证只输出1次。

  • 相关阅读:
    正则表达式基础以及应用
    日常使用之css篇
    echarts的使用总结
    &#65279导致页面顶部空白一行
    vue.js单页面应用实例
    BFC的外边距折叠
    .net 跳出Frameset框架
    Cache缓存使用
    Kafka集群搭建及安全机制手册
    PHP学习笔记
  • 原文地址:https://www.cnblogs.com/zjutzz/p/3207890.html
Copyright © 2011-2022 走看看