zoukankan      html  css  js  c++  java
  • poj-3087 Shuffle'm Up

    A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

    The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

    The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

    After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

    For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

    Input

    The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

    Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

    Output

    Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

    Sample Input

    2
    4
    AHAH
    HAHA
    HHAAAAHH
    3
    CDE
    CDE
    EEDDCC

    Sample Output

    1 2
    2 -1

    这题的题意好难好难理解啊,我读了半天又看了题解才反应过来。
    题意:给你三个字符串s1,s2,s12,规则是将s1和s2进行交叉堆放构成一个新的字符串st,判断这个新的字符串
    是否是目标字符串s12,若不是,则把s12平分成两块,最下面的c个构成新的s1,上面的构成新的s2,然后再交叉
    堆放构成字符串st,判断是否是目标字符串s12,若还不是,重复以上操作,直到找到或者找不到(出现重复的s12)
    为止。拿样例举个例:
    S1:AHAH                  HAAH
         交叉堆放st为HAAHHAAH!=s12 平分       重复操作……
    S2:HAHA                   HAAH

    知道题意就好理解了,就是道模拟题,附代码。
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <map>
    using namespace std;
    const int M = 211;
    char st1[M],st2[M],str[2*M],stu[M*2];
    int main(){
    	ios::sync_with_stdio(false);
    	int t;
    	cin>>t;
    	for(int k=1;k<=t;k++){
    		map<string,bool>mp;
    		memset(st1,0,sizeof(st1));
    		memset(st2,0,sizeof(st2));
    		memset(str,0,sizeof(str));
    		memset(stu,0,sizeof(stu));
    		int n;
    		cin>>n;
    		cin>>st1>>st2>>str;
    		mp[str]=1; 
    		int cnt=0;
    		while(1){
    			for(int i=0;i<n;i++){
    			stu[2*i]=st2[i];
    			stu[2*i+1]=st1[i];
    			}
    			stu[2*n]='';
    			cnt++;
    			if(!strcmp(stu,str)){
    				cout<<k<<" "<<cnt<<endl;
    				break;
    			}
    			else if(mp[stu]&&strcmp(stu,str)){
    				cout<<k<<" "<<-1 <<endl;
    				break;
    			}
    			mp[stu]=1;
    			
    			for(int i=0;i<n;i++){
    				st1[i]=stu[i];
    			}
    			st1[n]='';
    			for(int i=n;i<2*n;i++){
    				st2[i-n]=stu[i];
    			}
    			st2[n]='';
    		//	cout<<st2<<endl;
    		}
    	}
    	return 0;
    }
    

     这题有个地方我卡了没ac,就是stu数组的大小,我忘了给M*2,交上去说是wa,我找了好久好久啊,就是没找到T T。

     
  • 相关阅读:
    WinAPI: midiOutReset 重置输出设备
    WinAPI: midiOutLongMsg 向输出设备发送一条系统专用的 MIDI 消息
    WinAPI: midiInStart 启动输入
    WinAPI: midiOutClose 关闭输出设备
    WinAPI: midiInStop 停止输入
    bootstrap居中
    设计模式之访问者模式
    zend framework 开发环境搭建及入门
    转:GIT GUI使用
    Asp web.config详解
  • 原文地址:https://www.cnblogs.com/zmin/p/7306553.html
Copyright © 2011-2022 走看看