zoukankan      html  css  js  c++  java
  • uva Cube painting

     Cube painting 

    We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

    picture21

    Figure 1.

    Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a br, or g. The tex2html_wrap_inline128 character ( tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one changes into the other.

    tex2html_wrap138 tex2html_wrap140

    Input

    The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

    Output

    The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

    Sample Input

    rbgggrrggbgr
    rrrbbbrrbbbr
    rbgrbgrrrrrg

    Sample Output

    TRUE
    FALSE
    FALSE


    题意很简单,就是判断两个骰子是否相同。
    分析:分析可知1-6,2-5,3-4,所以两个骰子若相同的话,必定面对面的花色是一样的,所以只要判断两个骰子的所形成的三个对面是否都能够对应起来就可以了
    #include<stdio.h>
    #include<string.h>
    
    int main()
    {
        char str[20];
        int hash1[130][130],hash2[130][130];
        int i;
        while(scanf("%s",str)!=EOF)
        {
            memset(hash1,0,sizeof(hash1));
            memset(hash2,0,sizeof(hash2));
            for(i=0;i<=2;i++)
            {
                hash1[str[i]][str[5-i]]++;
                hash1[str[5-i]][str[i]]++;
            }
            for(i=6;i<9;i++)
            {
                 hash2[str[i]][str[17-i]]++;
                 hash2[str[17-i]][str[i]]++;
            }
            for(i=0;i<=2;i++)
            {
                if(hash1[str[i]][str[5-i]]!=hash2[str[i]][str[5-i]]) break;
            }
            if(i==3) printf("TRUE\n");
            else printf("FALSE\n");
        }
        return 0;
    }
  • 相关阅读:
    J2SE API & J2EE API & SSH API
    JSP转发和重定向的区别
    Tomcat详解
    面试题:通过问题排查,考察测试链路熟练程度
    c语言中求数组的长度
    CGContextBeginPath
    CGContextAddAr绘制一个圆弧
    将当前的手机屏幕上的视图控件的view拍照 并保存到手的album中
    CGContextFillPath(ctx)
    CGContextSetRGBFillColor
  • 原文地址:https://www.cnblogs.com/zsboy/p/2659066.html
Copyright © 2011-2022 走看看