zoukankan      html  css  js  c++  java
  • I

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

    Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

    '.' - a black tile 
    '#' - a red tile 
    '@' - a man on a black tile(appears exactly once in a data set) 
    The end of the input is indicated by a line consisting of two zeros. 

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output

    45
    59
    6
    13

    这道题依然是DFS求连通块,首先找到@,然后将它的值改成.,再对这一块进行填充就行,每填充一点,计数器就加一

    #include"iostream"
    #include"cstring"
    #include"cstdio"
    using namespace std;
    
    char a[101][101];
    int book[101][101];
    int n,m;
    int ans;
    
    void dfs(int x,int y,int z)
    {
    if(x<0||x>=n||y<0||y>=m)
            return;
    if(book[x][y]==1||a[x][y]!='.')
            return;
    book[x][y]=z;
    ans++;
    for(int i=-1;i<=1;i++)
    for(int j=-1;j<=1;j++)
    if(j==0||i==0) dfs(x+i,y+j,z);
    }
    
    int main()
    {
        while(scanf("%d%d",&m,&n)==2&&n&&m)
        {
       //  memset(a,0,sizeof(a));
         for(int i=0;i<n;i++) scanf("%s",a[i]);
         memset(book,0,sizeof(book));
         ans=0;
         for(int j=0;j<n;j++)
         for(int k=0;k<m;k++)
         {
            if(a[j][k]=='@') {a[j][k]='.';dfs(j,k,1);}
         }
    cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    代码收藏
    sql语句收藏
    网站收藏
    Api代码收集
    [网络收集]html 一个属性,多个数据
    [转] C#自定义的字符串操作增强类
    WebBrowser记录
    [转载]用C#的GDI+技术生成复杂型彩色验证码
    js addEventListener attachEvent用法
    正则表达式 获取常见所有标点符号
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4664892.html
Copyright © 2011-2022 走看看