zoukankan      html  css  js  c++  java
  • 集训第六周 数学概念与方法 J题 数论,质因数分解

    Description

    Tomorrow is contest day, Are you all ready? 
    We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final. 

    Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem. 
    what does this problem describe? 
    Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output. 
     

    Input

    Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.
     

    Output

    For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
     

    Sample Input

    60 12 -1
     

    Sample Output

    Case 1. 2 2 3 1 5 1 Case 2. 2 2 3 1

    Hint

     60=2^2*3^1*5^1 

    求质因数,使用循环求,数组记录就好
    #include"iostream"
    #include"cstring"
    #include"cstdio"
    using namespace std;
    const int maxn=65536+10;
    int vis[maxn];
    int main()
    {
        int n,ans,ca=1;
        while(cin>>n&&n>=0)
        {
         memset(vis,0,sizeof(vis));
         ans=n;
         int i=2;
         while(n!=1)
         {
             if(n%i==0)
             {
                 vis[i]++;
                 n/=i;
                 i=2;
             }
             else
                 i++;
         }
         if(ca!=1) cout<<endl;
         cout<<"Case "<<ca++<<"."<<endl;
         for(int j=0;j<=ans;j++)
         {
             if(vis[j]!=0) cout<<j<<" "<<vis[j]<<" ";
         }
         cout<<endl;
        }
        return 0;
    }
    View Code
     
  • 相关阅读:
    Vue 面试题汇总
    SSIS 通过OData源连接Dynamic 365 Online
    SQL Server AlwaysOn
    SQL Server AlwaysOn
    SQL Server AlwaysOn
    SQL Server AlwaysOn
    OGG同步ORACLE至SQLSERVER(转)
    Power BI Online管理数据源
    SSRS 动态设置分组依据及行组个数
    查看Reporting Services服务器中用户查询报表历史记录
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4744614.html
Copyright © 2011-2022 走看看