zoukankan      html  css  js  c++  java
  • Final Battle #1 K题 Fire game

    Description

    Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

    You can assume that the grass in the board would never burn out and the empty grid would never get fire.

    Note that the two grids they choose can be the same.

    Input

    The first line of the date is an integer T, which is the number of the text cases.

    Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

    1 <= T <=100, 1 <= n <=10, 1 <= m <=10

    Output

    For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

    Sample Input

    4 3 3
    .#.
    ###
    .#.
    3 3
    .#.
    #.#
    .#.
    3 3
    ...
    #.#
    ...
    3 3
    ###
    ..#
    #.#

    Sample Output

    Case 1: 1
    Case 2: -1
    Case 3: 0
    Case 4: 2
     
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    using namespace std;
    #define INF 1e9
    const int maxn=15*15+10;
    char a[15][15];
    int ta[maxn],tb[maxn],book[15][15],nex[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
    struct point
    {
        int x,y,z;
        point(int x=0,int y=0,int z=0):x(x),y(y),z(z){}
    };
    int m,n;
    
    int BFS(point aa,point cc)
    {
        queue<point>que;
        que.push(aa);que.push(cc);
        book[aa.x][aa.y]=1;book[cc.x][cc.y]=1;
        int step=0;
        while(!que.empty())
        {
            point temp=que.front();
            que.pop();
    
            step=max(step,temp.z);
            for(int k=0;k<=3;k++)
            {
                point pp;
                pp.x=temp.x+nex[k][0];
                pp.y=temp.y+nex[k][1];
                pp.z=temp.z+1;
                if(pp.x<0||pp.x>=m||pp.y<0||pp.y>=n) continue;
                if(book[pp.x][pp.y]||a[pp.x][pp.y]!='#') continue;
                book[pp.x][pp.y]=1;
                que.push(pp);
            }
        }
        return step;
    }
    
    int main()
    {
        int T,ca=1;
        cin>>T;
        while(T--)
        {
         cin>>m>>n;
         int k=0;
         for(int i=0;i<m;i++)
         for(int j=0;j<n;j++)
         {
             cin>>a[i][j];
             if(a[i][j]=='#')
             {
                 ta[k]=i;
                 tb[k++]=j;
             }
         }
         cout<<"Case "<<ca++<<": ";
         int ans=INF;
         for(int i=0;i<k;i++)
         for(int j=i;j<k;j++)
         {
             memset(book,0,sizeof(book));
             int step=BFS(point(ta[i],tb[i],0),point(ta[j],tb[j],0));
             int flag=1;
             for(int ki=0;ki<m;ki++)
             for(int kj=0;kj<n;kj++)
             if(a[ki][kj]=='#'&&book[ki][kj]==0) {flag=0;break;}
             if(flag) {ans=min(step,ans);}
         }
         if(ans==INF) cout<<-1<<endl;
         else cout<<ans<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    codewars sum of pairs
    codewars贪吃蛇算法题目
    记录一道有意思的js题目
    JS判断变量类型
    mock之初体验
    three.js尝试(二)模拟游戏开发:3D人物在地图上行走
    three.js尝试(一)模拟演唱会效果
    Vue中父组件使用子组件的emit事件,获取emit事件传出的值并添加父组件额外的参数进行操作
    网易前端工程师课程中,布局解决方案
    js飘窗
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4755779.html
Copyright © 2011-2022 走看看