zoukankan      html  css  js  c++  java
  • HDU 1711 Number Sequence(字符串匹配)

    Number Sequence

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 10571    Accepted Submission(s): 4814


    Problem Description
    Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
     


     

    Input
    The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
     


     

    Output
    For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
     


     

    Sample Input
    2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
     


     

    Sample Output
    6 -1
     


     

    #include<iostream>
    #include<cstdio>
    using namespace std;
    const int maxn1=1000010;
    const int maxn2=10010;
    int n,m;
    int a[maxn1];
    int b[maxn2];
    int next[maxn2];
    int main()
    {
     int kmp (int *a,int *b,int *next);
     int t,i;
     cin>>t;
     while(t--)
     {
      cin>>n>>m;
      for(i=0;i<n;i++)
      {scanf("%d",&a[i]);}
      for(i=0;i<m;i++)
      {scanf("%d",&b[i]);}
      int ans=kmp(a,b,next);
      cout<<ans<<endl;
     }
     return 0;
    }


    //此函数用来求匹配串s串的next数组
    void getnext (int *s,int *next)
    {
        next[0]=next[1]=0;
        for (int i=1;i<m;i++)//m为匹配串s的长度
     {
            int j=next[i];
            while (j&&s[i]!=s[j])
                j=next[j];
            next[i+1]=s[i]==s[j]?

    j+1:0;
        }
    }
    //此函数用来求匹配位置的值的函数。匹配不成功返回值-1
    int kmp (int *a,int *b,int *next)
    {
        getnext (b,next);/////////
        int j=0;
        for (int i=0;i<n;i++)
     {/////n为串1的长度
            while (j&&a[i]!=b[j])
                j=next[j];
            if (a[i]==b[j])
                j++;
            if (j==m)//m为串2的长度
                return i-m+2;
        }
        return -1;
    }


     

  • 相关阅读:
    luogu 1726 上白泽惠音
    POJ1419 Graph Coloring(最大独立集)(最大团)
    POJ2284 That Nice Euler Circuit (欧拉公式)(计算几何 线段相交问题)
    POJ 1966 Cable TV Network(顶点连通度的求解)
    POJ 1523 SPF(寻找关节点)
    Dwarves (有向图判环)
    POJ 3041 Asteroids(最小点覆盖集)
    POJ 1043 What's In A Name?(唯一的最大匹配方法)
    POJ Girls and Boys (最大独立点集)
    Jewelry Exhibition(最小点覆盖集)
  • 原文地址:https://www.cnblogs.com/zsychanpin/p/7298221.html
Copyright © 2011-2022 走看看